Pages: [1] 2   Go Down

Author Topic: Photos sent to Photoshop do not always come back to Lightroom  (Read 2052 times)

pflower

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 337
Photos sent to Photoshop do not always come back to Lightroom
« on: September 21, 2018, 02:43:28 pm »

This is happening more and more frequently.  I do some development on a Raw file in Lightroom and send it to Photoshop.  I do what I need to do in Photoshop and save it as a Tiff.  What should happen is Lightroom should import it automatically next to the original Raw file with the same keywords etc.  Sometimes this happens, but increasingly it does not.  I save a file and then return to Lightroom and what should happen is that the new saved Tiff should be selected in Lightroom.  Now - I would estimate about 50% of the time - I get the message that "no photo selected".  If I go to the grid view and find the original Raw file which now says "2of2" but I can't find "1 of 2" - i.e. the new Tiff.  If I then control click on the original Raw file and go to the folder in the Library the new Tiff is there, it has the right keyword (i.e. the same keyword as the original Raw file) but if I then filter the Library from the keyword it is not visible.  If I then quit Lightroom and restart - yes there it is - next to the original Raw file as it should be.

I am running an iMac under OSX 11.6  and the latest version of LR CC Classic and latest version of PS CC.  Sometimes things work as they should but increasingly they don't.  Since I am doing a lot of work in PS at the moment this is frustrating.  I don't think it is due to any sudden change of versions of LR or PS - this started several updates ago but only sporadically now it is happening at least 50% of the time and sometimes more.

Any thoughts? Mismatch between a slightly older OS and the recent newer versions of LR and PS or something else - corrupted preference files?  Apart from this my experience of LR and PS and their interaction is fast, effective and without any other problems.

Thanks for any suggestions.

 
Logged

Mark D Segal

  • Contributor
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 12509
    • http://www.markdsegal.com
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #1 on: September 21, 2018, 03:11:41 pm »

It happens to me once in a while, but I have no idea what causes it. Or, rather than not being there at all, the copy that should come back from Photoshop is lodged at the end of the image strip in Lr, rather than beside the image it is a copy of.
Logged
Mark D Segal (formerly MarkDS)
Author: "Scanning Workflows with SilverFast 8....."

digitaldog

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 15408
    • http://www.digitaldog.net/
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #2 on: September 21, 2018, 03:25:23 pm »

Try fixing all your disk permissions, maybe run something like Cocktail or similar on all drives. I don't see this issue, on a Mac too.
Logged
Andrew Rodney
Author “Color Management for Photographers"

JeanMichel

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 476
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #3 on: September 21, 2018, 06:00:19 pm »

It happens to me once in a while, but I have no idea what causes it. Or, rather than not being there at all, the copy that should come back from Photoshop is lodged at the end of the image strip in Lr, rather than beside the image it is a copy of.


Happens to me on occasion, although I now rarely go to PS, the saved tif does not appear where it should Then if I go to import the saved file it shows up as already imported, I go back to grid, and there it is! Annoying but it is a minor complaint. I am on a Mac.
Logged

FranciscoDisilvestro

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1441
    • Frank Disilvestro
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #4 on: September 21, 2018, 07:01:56 pm »

It might be a bug, but a few things to try:

- are you sure there is no filter active or are you located in a smart collection? it may be that the generated tiff does not satisfy the criteria
- In preferences - External editing tab - do you have checked the option "Stack with original" ?
- Try optimizing the catalog (File -> Optimize catalog)

Since you are on a Mac, the following is very unlikely, but have you installed any new antivirus tool?

Chris Kern

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 799
    • Chris Kern's Eponymous Website
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #5 on: September 21, 2018, 07:43:49 pm »

Any thoughts? Mismatch between a slightly older OS and the recent newer versions of LR and PS or something else - corrupted preference files?

I don't think this is caused by a mismatch between the operating system and application software because I experience this behavior occasionally on MacOS 10.13.6.

Or, rather than not being there at all, the copy that should come back from Photoshop is lodged at the end of the image strip in Lr, rather than beside the image it is a copy of.

I've seen this, too.  I suspect—but have been too lazy to rigorously test—that this display strangeness only occurs when the LR library module is configured to sort according to Custom Order.  When I experience this problem, and then change the sort sequence to Capture Time, the previously "missing" Photoshop TIFFs (which actually seemed to be hiding at the bottom of the image strip in Lightroom), magically reappear where I expected to find them.  I don't think I've had this happen when I start the round-trip to PS with the sort order set to Capture Time, but, again, I haven't performed any rigorous tests.

If there is a bug, my instinct is that it is related to either a race condition between the two applications or to Photoshop not ending the round-trip by depositing the rendered files in the manner Lightroom expects.

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 701
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #6 on: September 21, 2018, 08:31:03 pm »

I'm about 60/40 on this. One of my three LR systems is nearly 100% successful, but I have no idea why. Either way, I have the Synchronize Folder as a habit now. Solves the problem, of course.
Logged

Wayne Fox

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 4225
    • waynefox.com
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #7 on: September 22, 2018, 12:41:13 am »

This is happening more and more frequently.  I do some development on a Raw file in Lightroom and send it to Photoshop.  I do what I need to do in Photoshop and save it as a Tiff.  What should happen is Lightroom should import it automatically next to the original Raw file with the same keywords etc.  Sometimes this happens, but increasingly it does not.  I save a file and then return to Lightroom and what should happen is that the new saved Tiff should be selected in Lightroom.  Now - I would estimate about 50% of the time - I get the message that "no photo selected".  If I go to the grid view and find the original Raw file which now says "2of2" but I can't find "1 of 2" - i.e. the new Tiff.  If I then control click on the original Raw file and go to the folder in the Library the new Tiff is there, it has the right keyword (i.e. the same keyword as the original Raw file) but if I then filter the Library from the keyword it is not visible.  If I then quit Lightroom and restart - yes there it is - next to the original Raw file as it should be.

I am running an iMac under OSX 11.6  and the latest version of LR CC Classic and latest version of PS CC.  Sometimes things work as they should but increasingly they don't.  Since I am doing a lot of work in PS at the moment this is frustrating.  I don't think it is due to any sudden change of versions of LR or PS - this started several updates ago but only sporadically now it is happening at least 50% of the time and sometimes more.

Any thoughts? Mismatch between a slightly older OS and the recent newer versions of LR and PS or something else - corrupted preference files?  Apart from this my experience of LR and PS and their interaction is fast, effective and without any other problems.

Thanks for any suggestions.
from reading this it sounds like it is importing the file, but how LR responds is different. From what I can see you aren’t having to sync the folder to get LR to find it? But for some reason it doesn’t necessarily show up and somehow the keywords are not responding to searches correctly?

I go to PS with almost every file, and I don’t recall when coming back having an issue.  When you are saving the file, are you doing a save as or are you just saving it?
« Last Edit: September 22, 2018, 12:44:33 am by Wayne Fox »
Logged

Mark D Segal

  • Contributor
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 12509
    • http://www.markdsegal.com
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #8 on: September 22, 2018, 08:23:13 am »

It might be a bug, but a few things to try:

- are you sure there is no filter active or are you located in a smart collection? it may be that the generated tiff does not satisfy the criteria
- In preferences - External editing tab - do you have checked the option "Stack with original" ?
- Try optimizing the catalog (File -> Optimize catalog)

Since you are on a Mac, the following is very unlikely, but have you installed any new antivirus tool?

These are useful suggestions - thanks Francisco.
Logged
Mark D Segal (formerly MarkDS)
Author: "Scanning Workflows with SilverFast 8....."

Mark D Segal

  • Contributor
  • Sr. Member
  • *
  • Offline Offline
  • Posts: 12509
    • http://www.markdsegal.com
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #9 on: September 22, 2018, 08:25:17 am »

When you are saving the file, are you doing a save as or are you just saving it?

Good point - and for clarity - one should usually do "Save" if the intention is to just bring it back into Lr.
Logged
Mark D Segal (formerly MarkDS)
Author: "Scanning Workflows with SilverFast 8....."

pflower

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 337
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #10 on: September 22, 2018, 11:59:53 am »

Thanks for all suggestions.

I have optimised the catalog, I do have "stack with original" checked and I always just "save" rather than "save as" out of PS.  I am not sure it is possible to repair disk permissions any longer on Macs but I did run Disk Utility on the disks with the catalog, app and photos.  No change.

Things are now getting weirder.  I have just spent the morning editing 15 photos in LR and sending each of them to PS.  Not a single one was re-imported correctly. In order to get them into LR I have to quit and re-start which is a serious pain.   But there are stranger things afoot....

I have filtered the photos from their keywords.  So they are not in a collection and are sorted by capture time.  When I send a photo to PS and return to LR I get the "no photo selected" message - i.e. the Photo edited in PS has not been imported  into the filtered selection, but also the Raw file that was selected (i.e. the one that I used to go to PS with) has been de-selected - hence the "no photo selected" message.  It has also been moved to the very end of the filtered selection even though its time stamp has not been altered.

PS has saved the edited photo in the right folder and it has got the keywords attached to the Raw File but it does not show up when I try and filter via keyword until I quit LR and restart.  Then it does show up but not next to the original Raw file.  The original Raw file has moved back to its correct position as determined by the capture time and is no longer at the end of the filtered selection, but the new edited photo has the right date but the time stamp is some 2 hours later than the original Raw file.

Whilst I have noticed this from time to time in the past, this is now standard behaviour.  I found that I wasn't on the most recent version of LR and so updated.  No improvement.
Logged

tonysiciliano1

  • Newbie
  • *
  • Offline Offline
  • Posts: 40
    • Tony Siciliano Photography
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #11 on: September 22, 2018, 01:02:19 pm »

Have you reset LR preferences? If not try that. If no luck with that, try uninstalling LR (save your preferences) and reinstall it. That has occasionaly worked for me for fixing buggy behavior.
Logged

digitaldog

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 15408
    • http://www.digitaldog.net/
Logged
Andrew Rodney
Author “Color Management for Photographers"

pflower

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 337
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #13 on: September 22, 2018, 02:53:54 pm »

Thanks, but that link brings up an error message.

Problem still persists, and is now happening 100% of the time.  I am beginning to lose more hair - and I don't have a lot to spare.

I am beginning to think that either I have discovered a bug (unlikely since no one else really seems to have experienced this to the level I have), there is a weird corruption in my Catalog file or some mismatch between my OSX 11.6 and recent versions of LR CC.

I have:

Re-set preferences by restarting LR holding down the control and R keys;
Run Disk Utility and Diskwarrior on all disks and discovered that Diskwarrior will repair disk permissions so did that as well;
Uninstalled LR CC from the Creative Cloud and then updated.
Optimised the Catalog

The problem continues and appears to be related to the Custom Filter from the Keyword List.

My normal workflow is to filter photos via keywords, so I have, let us say 200 photos with the same keyword.  Sending a Raw File to PS and then saving it results in PS saving the Tiff to the right folder and the keyword count rises by 1 - so there are now (theoretically) 201 photos with the same keyword.  But the new Tiff is not visible when filtered via that keyword.  But if I turn Filters off - so have all photos in my catalog visible then it is there.  Only when I restart LR does it appear in in the keyword filtered selection.

No idea what is happening or why.  But I wonder if my catalog is somehow glitched if not corrupted.  I suppose the next step is to go back to an earlier backup. At least the problems are mostly related to Tiffs so losing edits in the History panel won''t affect them.  But still a lot of work.  I have been using LR since version 1 and have never ever had such a problem.

I might try and contact Adobe.  Anyone got a route to contacting customer support that works?

Thanks




Specifically:
https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/
Logged

FranciscoDisilvestro

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1441
    • Frank Disilvestro
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #14 on: September 22, 2018, 04:59:14 pm »


No idea what is happening or why.  But I wonder if my catalog is somehow glitched if not corrupted.  I suppose the next step is to go back to an earlier backup. At least the problems are mostly related to Tiffs so losing edits in the History panel won''t affect them.  But still a lot of work.  I have been using LR since version 1 and have never ever had such a problem.


This looks like a bug or issue with your specific setup. I have repeated your workflow (windows 10) and it works fine. It does not look like a catalog issue, otherwise it would be present after you restart LR. I was going to suggest to clear the cache, but since you uninstalled and reinstalled LR, that should not be either.

john beardsworth

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 4576
    • My photography site
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #15 on: September 23, 2018, 03:23:03 am »

"Sending a Raw File to PS "

Exactly which commands are you using to do this? Are you using Edit With, or Export?

"and the keyword count rises by 1 - so there are now (theoretically) 201 photos with the same keyword.  But the new Tiff is not visible when filtered via that keyword.  But if I turn Filters off - so have all photos in my catalog visible then it is there.  Only when I restart LR does it appear in in the keyword filtered selection."

This implies that things are working properly, but your filter is targeting more than you think - eg filtering on the keyword and on raw files. Do things work normally if you begin by disabling the filter with Cmd L or hitting None in the Library Filter bar, before you send the file to PS? How are you enabling the filter? By clicking the arrow in the keyword list, or by some other way - how?

pflower

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 337
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #16 on: September 23, 2018, 08:14:30 am »

I am simply going to Photo/Edit In then choosing Photoshop which is set up as an external editor.  This works as expected.

The problem is with my Custom Filter - selecting photos by keyword.  I have been selecting photos simply by clicking on the arrow next to the keyword in the Library module. 

I am not sure what you mean by "hitting None in the Library Filter bar".  But if I choose the option of turning the filters off from the drop down menu at the bottom right (so that all photos in the catalog are visible) then things work - sort of.  Returning to LR with Filters off I still get No Image Selected but then if I go the grid view and sort by Edit Time the original Raw File and the new Tiff are visible.  However even though it has the same keyword as the Raw File the new Tiff is not visible when selecting photos with that keyword until I restart LR.

There is a work around - put all photos that I am working on in a collection, turn filters off and work out of the collection - the new Tiff is imported into the collection.

The other weird thing is that seemingly on my Hasselblad X1D the time stamp for the new Tiff is approximately 2 hours later than the time stamp on the Raw file.  Other cameras don't appear to be affected by this.

"Sending a Raw File to PS "

Exactly which commands are you using to do this? Are you using Edit With, or Export?

"and the keyword count rises by 1 - so there are now (theoretically) 201 photos with the same keyword.  But the new Tiff is not visible when filtered via that keyword.  But if I turn Filters off - so have all photos in my catalog visible then it is there.  Only when I restart LR does it appear in in the keyword filtered selection."

This implies that things are working properly, but your filter is targeting more than you think - eg filtering on the keyword and on raw files. Do things work normally if you begin by disabling the filter with Cmd L or hitting None in the Library Filter bar, before you send the file to PS? How are you enabling the filter? By clicking the arrow in the keyword list, or by some other way - how?
Logged

JeanMichel

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 476
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #17 on: September 23, 2018, 11:45:47 am »

Could it be that you have previously selected, in library grid, files to be raw, etc., but not include tiff files? The result would be to show only the selected file types, and in this case exclude the tiff files.
Logged

mdijb

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 571
    • mdiimaging.com
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #18 on: September 23, 2018, 02:18:59 pm »

Try this step.  WHen this happens to me I make sure you are in Library mode--Rt. Click on the folder and select"synchronize folder".  Lr may then import the file you are trying bring back into LR.

I read about this but can't remember where but it seems to work most of the time.

MDIJB
Logged
mdiimaging.com

john beardsworth

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 4576
    • My photography site
Re: Photos sent to Photoshop do not always come back to Lightroom
« Reply #19 on: September 23, 2018, 04:20:04 pm »

The problem is with my Custom Filter - selecting photos by keyword.  I have been selecting photos simply by clicking on the arrow next to the keyword in the Library module. 

How is LR filtered immediately before you Edit in Photoshop? Are you filtering the photos by clicking on the arrow, or are you doing something else? There is nothing in LR that is called a "Custom Filter", but there is a Filter Preset which you can save from the little menu on the Library Filter (the 4+ columns at the top of the grid). If you are using a Filter Preset, you may have included the file type in it, which will mean that only raw files are shown and the new PSD/TIF isn't. Reopening LR releases the filter, which explains why you would then see the PSD/TIF.
Pages: [1] 2   Go Up