Pages: 1 [2] 3   Go Down

Author Topic: Brush Lag: LR CC Classic  (Read 5514 times)

nemophoto

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 803
    • Nemo Niemann Photography
Re: Brush Lag: LR CC Classic
« Reply #20 on: February 19, 2018, 02:56:16 PM »

Iím working on a new PC (my old one was still pretty burly, but 4+ years old). Iíve alway experiences the lag, at least for the past four years or so. My new computer uses an AMD Ryzen 7 1800x , 32GB RAM, a Samsung 960 m.2 512GB SSD for my C: drive and an NVidia 1080 with 8GB of vram. So, not a weakling, but LR seems to bog it down. And like you, makes no difference whether I have the GPU turned on or off.

I think this will remain the great mystery. Meanwhile, Iíll keep experimenting with other software more.


Sent from my iPhone using Tapatalk

john beardsworth

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 4341
    • My photography site
Re: Brush Lag: LR CC Classic
« Reply #21 on: February 19, 2018, 03:03:30 PM »

I really don't think it's helpful to say "I have read whatever" without providing the URL or source. I generally discount such comments, but the data for a brush stroke is considerably more complex than a radial filter. That happens to be why I always use it in preference to the brush, even if I know it shouldn't make a difference in practice - the stroke should update the screen in real time and can be written to the database in the background.

But it would be interesting to see if the same catalogue produced screen redrawing lags differently when on a USB drives but not on FW. I tried adding 50+ brush strokes today on Windows and didn't see any issues.

nemophoto

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 803
    • Nemo Niemann Photography
Re: Brush Lag: LR CC Classic
« Reply #22 on: February 19, 2018, 05:42:22 PM »

Adobeís comments on optimization. About halfway down, the limitation of brush strokes as well as order of execution.
https://helpx.adobe.com/lightroom/kb/optimize-performance-lightroom.html


Sent from my iPhone using Tapatalk

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #23 on: February 20, 2018, 07:51:01 PM »

I really don't think it's helpful to say "I have read whatever" without providing the URL or source. I generally discount such comments, but the data for a brush stroke is considerably more complex than a radial filter. That happens to be why I always use it in preference to the brush, even if I know it shouldn't make a difference in practice - the stroke should update the screen in real time and can be written to the database in the background.

But it would be interesting to see if the same catalogue produced screen redrawing lags differently when on a USB drives but not on FW. I tried adding 50+ brush strokes today on Windows and didn't see any issues.

John, I have tested the following:

1) External drive that has previously exhibited brush lag when connected via USB 2 to a 5AK iMac, connected instead by FW800 via TB > FW adapter.
2) Brush lag is bad, although better than when same drive is connected via USB 2 to same iMac.
3) This external drive contains LR Classic CC catalog and images.
4) Identical drive shows no lag when connected to older iMac, via "native" FW800 bus.
4) Both machines run same CC Classic version and OS.

Clear as mud.

John-
Logged

john beardsworth

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 4341
    • My photography site
Re: Brush Lag: LR CC Classic
« Reply #24 on: February 21, 2018, 04:38:26 AM »

So John, on the iMac in pts 1-2, what is lag like if the catalogue is on the internal hard drive?

It might also be worth seeing if there is a difference between adding brush strokes with the Wacom and with the mouse.

Also "5AK" - you mean a 5k monitor or is there some significance I am missing in the A? The older iMac mentioned in pt 4 runs what type of monitor?

John

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #25 on: February 22, 2018, 08:14:16 AM »

So John, on the iMac in pts 1-2, what is lag like if the catalogue is on the internal hard drive?

It might also be worth seeing if there is a difference between adding brush strokes with the Wacom and with the mouse.

Also "5AK" - you mean a 5k monitor or is there some significance I am missing in the A? The older iMac mentioned in pt 4 runs what type of monitor?

John

1) I've not yet tried moving the catalog to an internal drive, but will do so
2) No appreciable difference in lag when brush strokes are made via mouse or via Wacom pen
3) A very clear pattern is that when a catalog is first opened, the first several brush strokes do not lag. As brush strokes pile up on a single image, or even on a new image, the lag grows. Closing and reopening the catalog starts the process over again.
4) 5K iMac is what was meant.
5) The "old" iMac machine run the 2560 x 1440 27" displays.

Thanks, John.

John-
Logged

John Cothron

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 348
    • Cothron Photography
Re: Brush Lag: LR CC Classic
« Reply #26 on: February 28, 2018, 12:35:28 PM »

I got lag with repeated brush strokes (and spot healing as well) up through the 7.1 version.  With the 7.2 update that issue seems to be resolved.  I never noticed that GPU acceleration hurt or helped when I tested it previously.  I use a wacom tablet in combination with a keyboard.
Logged
John
Flickr

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #27 on: March 02, 2018, 04:11:58 PM »

I got lag with repeated brush strokes (and spot healing as well) up through the 7.1 version.  With the 7.2 update that issue seems to be resolved.  I never noticed that GPU acceleration hurt or helped when I tested it previously.  I use a wacom tablet in combination with a keyboard.

7.1 is unusable here once Brush use is heavy. Makes no difference if catalog is small or large, or if catalog and files are on separate drives. Updating to 7.2 now, based on your experience John.

Thanks very much,

John Caldwell
Logged

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #28 on: March 02, 2018, 04:39:21 PM »

7.2 is no better, I'm sad to report, than 7.1. Brush strokes require about 20 seconds, with each stroke, to recover. Unusable is a fair term to use. For now, Photoshop is the only way to do the kind of masked adjustments that have, for years until recently, been possible with LR.
Logged

John Cothron

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 348
    • Cothron Photography
Re: Brush Lag: LR CC Classic
« Reply #29 on: March 05, 2018, 10:50:18 AM »

7.2 is no better, I'm sad to report, than 7.1. Brush strokes require about 20 seconds, with each stroke, to recover. Unusable is a fair term to use. For now, Photoshop is the only way to do the kind of masked adjustments that have, for years until recently, been possible with LR.

I'm sorry to hear that.  The variation in experiences people have is hard for me to understand.  Using 7.2 I edited 30 or so shots yesterday, after sorting through 100 or so with basic edits.  I never had the slow down.

I wonder if it has anything to do with system set-up/hardware.  You have probably mentioned what you are running earlier but I don't recall.  I'm running Windows 10, 512GB M2 SSD for the catalog, using a i7-7600 with 32GB of ram.  I have a Nvidia GTX 1060 video card.  The raw images are stored on a 4 disk array of 7200 rpm WD drives.
Logged
John
Flickr

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #30 on: March 05, 2018, 02:38:41 PM »

I'm sorry to hear that.  The variation in experiences people have is hard for me to understand.  Using 7.2 I edited 30 or so shots yesterday, after sorting through 100 or so with basic edits.  I never had the slow down.

I wonder if it has anything to do with system set-up/hardware.  You have probably mentioned what you are running earlier but I don't recall.  I'm running Windows 10, 512GB M2 SSD for the catalog, using a i7-7600 with 32GB of ram.  I have a Nvidia GTX 1060 video card.  The raw images are stored on a 4 disk array of 7200 rpm WD drives.

John, How many adjustment brush strokes might you use in a given image? My systems are fine until there are about 10 strokes in an image, after that, no good.

These are iMac systems.
Logged

John Cothron

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 348
    • Cothron Photography
Re: Brush Lag: LR CC Classic
« Reply #31 on: March 05, 2018, 03:16:24 PM »

John, How many adjustment brush strokes might you use in a given image? My systems are fine until there are about 10 strokes in an image, after that, no good.

These are iMac systems.

Easily more than 10.  I just did a rough count on the history of one I edited last night and I had 60ish brush strokes on that one.
Logged
John
Flickr

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #32 on: March 05, 2018, 04:36:33 PM »

Yes the inconsistency is puzzling. Even one of our three iMac systems allows heavy adjustment brush without lag. But Iím feeling discouraged. For some time Iíve so enjoyed being able to do all, or most, of my PP with going to Photoshop. The lag weíre discussing here renders PS a necessity most of the time on my laggy systems.


Sent from my iPhone using Tapatalk
Logged

John Cothron

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 348
    • Cothron Photography
Re: Brush Lag: LR CC Classic
« Reply #33 on: March 05, 2018, 04:51:37 PM »

John just out of curiosity but have you tried wiping the system clean and reinstalling? Operating system and everything?


Sent from my iPhone using Tapatalk
Logged
John
Flickr

ukmdb

  • Newbie
  • *
  • Offline Offline
  • Posts: 6
  • Nottingham Photographer - UK
    • John Price Photography
Re: Brush Lag: LR CC Classic
« Reply #34 on: March 22, 2018, 09:01:50 AM »

I first suffered with major lags in developer over a year ago.
My system is a Windows 10 3.6Ghz Xeon processor with 8 cores, 64GB ram,  Samsung 960 1TB m.2 disk
My system is no slouch, But Lightroom just does not take advantage of the cores or the memory.
This got so bad I moved to CaptureOne Pro 9 (now 10) This was ground breaking, Finally I can perform multiple adjustments, edit in PS and come back, skip, skip, skip to the next image is such a breeze.

I have read recently of the performance improvements made in Lightroom, unfortunately for some they are just as bad. The import and export is now quicker but the adjustments tools are still SLOWWW....

They need to rebuild from scratch before they lose it all together.
So many are now fleeing to CaptureOne and I do not blame them.
If you not tried it yet, then download the free trial and best of all if you come from lightroom then there is a setting you can choose which lays everything out to make it look just like lightroom.
You just got to get used to using sessions instead of catalogs.

Logged
Nottingham wedding photographer
https://www.johnpricephotography.co.uk
I shoot Canon > Envy the Sony

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #35 on: March 29, 2018, 08:48:05 AM »

I first suffered with major lags in developer over a year ago.
My system is a Windows 10 3.6Ghz Xeon processor with 8 cores, 64GB ram,  Samsung 960 1TB m.2 disk
My system is no slouch, But Lightroom just does not take advantage of the cores or the memory.
This got so bad I moved to CaptureOne Pro 9 (now 10) This was ground breaking, Finally I can perform multiple adjustments, edit in PS and come back, skip, skip, skip to the next image is such a breeze.

I have read recently of the performance improvements made in Lightroom, unfortunately for some they are just as bad. The import and export is now quicker but the adjustments tools are still SLOWWW....

They need to rebuild from scratch before they lose it all together.
So many are now fleeing to CaptureOne and I do not blame them.
If you not tried it yet, then download the free trial and best of all if you come from lightroom then there is a setting you can choose which lays everything out to make it look just like lightroom.
You just got to get used to using sessions instead of catalogs.

I'm terribly reluctant to leave LR, as I depend on LR for many things, foremost of which is image organization. Brush lag has become terrible, as you say, and I've not been able to get to the bottom of the problem. I will say that when brusk strokes are few in number and small in surface area for a given image, the lag is quite manageable. I suspect a reason that some LR users don't experience meaningful lag is their workflow is less adjustment brush dependent than mine has been.

Either way, I do hope that Adobe will address performance in the near future and place that is a high priority.

Thanks to all,

John Caldwell
Logged

Wayne Fox

  • Sr. Member
  • ****
  • Online Online
  • Posts: 4087
    • waynefox.com
Re: Brush Lag: LR CC Classic
« Reply #36 on: March 29, 2018, 06:31:28 PM »

I havenít noticed any issues, but I just ran a test.  A file from my IQ3 100 I added over 100 spot removal locations, some drawn, others simply clicks.  While it seemed slightly less responsive by the end, it really was insignificant. I reverted the file, did several global adjustments, as well as add some graduated filters.  I again used the spot removal tool to create over 100 locations, again with no perceptible change.  I then added some adjustment brushes and created some local adjustments, and even when using the automask function I had no problems at all.

This is on my laptop, after I had been working on several images for the past couple of hours, without relaunching LR. Lightroom, the files, and the catalog all reside on the Laptopís internal SSD which does offer pretty astounding performance (write speed 1600 MB/s, read speed almost 2000 MB/s).

I do know that if I have done extensive work on a file before I do  spot removal that can get laggy.  Not uncommon for me since I usually am trying to decide how much time I want to invest in a file so I have several adjustments, some graduated filters, and often two or three extensive brush adjustments. In this case I make a virtual copy, revert the file, do all the spot removal, then sync the spot removal over to the other file.

Your experience that one machine performs better has me curious because it seems this is better than what Iíve seen on my MacPro with 64gigs of ram where I do most of my LR/PS work.  I think Iíll test it tonight. The main difference is LR and the files are mounted from my Laptop using target disk mode, with far less speed, but there maybe some underlying differences which is causing such a diverse range of performance for users (which may or may not be something Adobe can actually do something about).
Logged

John Caldwell

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 649
Re: Brush Lag: LR CC Classic
« Reply #37 on: March 29, 2018, 07:03:04 PM »

I havenít noticed any issues, but I just ran a test.  A file from my IQ3 100 I added over 100 spot removal locations, some drawn, others simply clicks.  While it seemed slightly less responsive by the end, it really was insignificant. I reverted the file, did several global adjustments, as well as add some graduated filters.  I again used the spot removal tool to create over 100 locations, again with no perceptible change.  I then added some adjustment brushes and created some local adjustments, and even when using the automask function I had no problems at all.

This is on my laptop, after I had been working on several images for the past couple of hours, without relaunching LR. Lightroom, the files, and the catalog all reside on the Laptopís internal SSD which does offer pretty astounding performance (write speed 1600 MB/s, read speed almost 2000 MB/s).

I do know that if I have done extensive work on a file before I do  spot removal that can get laggy.  Not uncommon for me since I usually am trying to decide how much time I want to invest in a file so I have several adjustments, some graduated filters, and often two or three extensive brush adjustments. In this case I make a virtual copy, revert the file, do all the spot removal, then sync the spot removal over to the other file.

Your experience that one machine performs better has me curious because it seems this is better than what Iíve seen on my MacPro with 64gigs of ram where I do most of my LR/PS work.  I think Iíll test it tonight. The main difference is LR and the files are mounted from my Laptop using target disk mode, with far less speed, but there maybe some underlying differences which is causing such a diverse range of performance for users (which may or may not be something Adobe can actually do something about).
Wayne the lag Iím speaking about is quite specific to the Adjustment Brush. Once the number of strokes exceeds about 6, or if a given stroke covers a large surface area, lag is intense. I can still not account for why one of our three systems doesnít lag.


Sent from my iPhone using Tapatalk
Logged

Wayne Fox

  • Sr. Member
  • ****
  • Online Online
  • Posts: 4087
    • waynefox.com
Re: Brush Lag: LR CC Classic
« Reply #38 on: March 30, 2018, 12:12:56 AM »

Wayne the lag Iím speaking about is quite specific to the Adjustment Brush. Once the number of strokes exceeds about 6, or if a given stroke covers a large surface area, lag is intense. I can still not account for why one of our three systems doesnít lag.
Sent from my iPhone using Tapatalk
I wasn't sure which brush, so the second test with the adjustment brush had 4 different "brushes", about 100 strokes total of various sizes. I'm not sure at what point you see to hit "lag".  maybe it's more than that.

I will admit that most of my work with adjustment brushes is not "painted" on but is created using the automask option to select various tones and colors.  I'm not sure how that works, since in 4 or 5 clicks I may end up with a selection covering 30-50% of the image, but it's only a few clicks.  I'm not really sure how adobe is recording and managing adjustment brushes, I assumed it was more like an accumulative mask, but from what you are seeing it's more of a track every click and release point etc.  I realize it's metadata so maybe that's the only way it can work.

I just find it odd that if one of 3 systems doesn't lag, and if several others mention they aren't seeing the lag how Adobe could track it down, since it seems to be something outside of their software.  obviously some interaction going on.  I assume you've tried it with graphics processor off, etc., all the normal things to try, and maybe watched the activity monitor to see if the two machines have something grabbing some processor time that the good machine isn't.

As I mentioned, my laptop seems to perform better than my desktop so I'm going to keep testing.
Logged

John Cothron

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 348
    • Cothron Photography
Re: Brush Lag: LR CC Classic
« Reply #39 on: April 09, 2018, 01:46:15 PM »

John you may have done this already, but have you examined your processor usage, memory, etc. before and during that times it is "lagging"?  I wonder if something may show up there, at least where the bottleneck is.

FWIW I'm still not seeing any lag with the adjustment brush.  I DO see some slow down when I have gone through hundreds of images, discarding, re-writing meta-data, etc.  I've been going back through my catalog and getting rid of things I know I'm never going to do anything with and I've seen some slow down after doing a LOT of that.
Logged
John
Flickr
Pages: 1 [2] 3   Go Up