Pages: [1]   Go Down

Author Topic: Epson 1430 Non-OEM Cartridge Issues  (Read 1190 times)

Remo Nonaz

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 385
    • Photography By Homer Shannnon
Epson 1430 Non-OEM Cartridge Issues
« on: January 22, 2013, 04:09:40 PM »

I have an Epson 1400 printer that I use for black and white printing. The B&W requires non-OEM, refillable cartridges, which I purchase from MIS Associates ( I have never had any issues with these and I swap them in and out with MIS color carts and Epson carts as my printing needs require.

I purchased a new Epson 1430, which is essentially the same printer as the 1400, uses the same Epson 79 ink cartridges but has WiFi networking. I set up the 1430 and got it all ready to print. I installed my MIS color cartridges and pressed the 'drop' button to cycle the cartridge load. When finished, none of the six LEDs in the cartridge carriage went out. When I tried printing, the printer dialog box stated that there was no ink loaded in the printer. I swapped my MIS color cartridges with Epson cartridges and the printer worked perfectly.

This would normally be fine, but I need the printer to work with the 3rd party cartridges as that is how I do 90% of my printing. I have spoken with others who use the 1430 with 3rd party cartridges successfully. The cartridges I am using are the MIS ARC-T079 model and their chip is labeled with 79xR where x=1 to 6, and they have a v6.0 mark. I have asked MIS about this but have not received a response yet.

Is anyone aware of what Epson may have changed in this  printer and what can be done about it or is there some trick to get the printer to work with non-OEM cartridges?
I really enjoy using old primes on my m4/3 camera. There's something about having to choose your aperture and actually focusing your camera that makes it so much more like... like... PHOTOGRAPHY!

Paul Roark

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 368
Re: Epson 1430 Non-OEM Cartridge Issues
« Reply #1 on: January 24, 2013, 06:55:44 PM »


Apparently there was a slight change in the 1430 that required new third party chips.

Pages: [1]   Go Up