Epson 7900 from the inside - out

Started by Eric Gulbransen, January 26, 2012, 08:44:43 pm


March 18, 2015, 12:39:04 am #1520 Last Edit: March 28, 2015, 12:53:17 am by disneytoy
So, I replaced the 4 ink carts in the 9890 as the cleaning process requested, but now a new (2012) 350ml light Light Black shows "X" INK CARTRIDGE ERROR: REPLACE CARTRIDGE.

I removed it twice. restarted the printer both regular and Service mode.

The cart was sealed. I cleaned the circuit board with some alcohol. Still have an X?

Any workarounds?


UPDATE: Epson replaced the Cartridge. Back to printing.





After some googling, I tried tapping the LL Black cartidge. Used an eraser on the circuitboard. No luck.

Reading elsewhere here, I removed the Light Black neighbor. Closed the cover, the printer now reads a full LL Black but obviously a missing LT Black. So installed the missing cart and back to having the Lt Lt Black with a red "X"

If I reinstall the near empty LT and LT LT BLACK carts, they show up.

So, the printer will recognize the Lt Lt Black if the Lt Black space is empty.


We have a Epson 9700 that appeared to have a clogged head. After trying various cleanings etc we took the head off and cleaned as suggested at this and other sites using Windex and Rubbing Alcohol. Dried and back in printer. New nozzle check shows exactly the same clogged pattern for the Matte Black as it was before we took the head off and cleaned it. Tried this four times. Same clogged pattern.

Replaced the ink dampers. Same problem and exactly the same clogged nozzle check patten for the Matte Black.

Before we invest in a new print head, could this be caused by a air leak or something else.

Also any suggestions as to a reliable vendor to buy a replacement head for the Epson 9700. We are located in the middle of the Pacific so a Epson service call is out of the question.

Many thanks

Nozzle Check pattern;


I have a similar problem with a 9700 pro. Coincidence, today I spoke with an Epson technician that confirmed the head is dead.

But, in my case I am not willing to spend 2000 euros for a head change, for that money I can buy a new 36 inch Canon.


I am trying to find servpro.exe. If anyone has a suggestion to where I may get this program please email me at

Thank you,  David


I sent you a link to what you need.



Hi everyone. I'm new here.
Please excuse if I ask any questions which have been answered already in other posts or threads I couldn't find after some searching here.
I came here because I found Erics report on his Epson 7900.

I have an Epson 4900, three years old. It had the "usual" clogs after little more than one year, and I was able to persuade Epson to exchange the printhead on guarantee. The printer worked quite well, but a couple of days ago, the clogs appeared again and the printhaed finally died:
At first, I got the error massage "Call for Servive Code 131B", which disappeared after turning off and on the printer again. However, the black and subsequently the LK lost more and more dots with every try.
Then, finally, the printer turned to the error message "fatal error 1A39" and stopped working.

I changed the printhead - after having found Erics thread here and his great video on replacing the printhaed in his 7900. Thanks a lot!
Changing the printhead wasn't too difficult. I did an ink eject twive, then started to replace the head, and everything worked well. Or, nearly so - at first. Then...
The puzzling thing is: The printer works, and after two or three normal cleanings and an exchange of the almost empty MK cartridge, the nozzle test was ecellent, no missing dots.
I changed to PK, and there was no black at all. Changing back to MK: no black. The LK had some spaces in the nozzle check but finally came back.

After reading through this thread and some other posts, I'm wondering whether its the damper unit. Any ideas?


Update: I did a LC3 cleaning using the service programm for the black and LC. That did work, the black is back. Maybe there were some air bubbles in the printhead?
I cannot change the black ink at the moment, because the waste ink tank is full. Will get a new one tomorrow. Cross fingers.


I am new here
on my epson  9900
i see it is a wiper blade problem
can i fix it my self??


December 10, 2016, 10:49:42 pm #1529 Last Edit: December 11, 2016, 12:37:57 am by dod488
I need to reseat the print head cables on my 7900.    My issue is that I've got the "Call for Service - error 1a37" message on the lcd.   I need to open the ink cover doors to release pressure.   But the error message keeps the door release button from functioning.   I don't know how to clear the error msg.   Alternatively, if there some other way to open the ink covers that would work too.

Suggestions?   Thanks very much.   Need to print for a show coming up.   Argh!

Thanks again, Hal Work