Pages: [1]   Go Down

Author Topic: 5d mk II and Sigma 500 DG SUPER Flash  (Read 3510 times)

palmerson

  • Newbie
  • *
  • Offline Offline
  • Posts: 29
5d mk II and Sigma 500 DG SUPER Flash
« on: December 16, 2008, 06:32:03 pm »

Hey All. I just picked up my copy of the new 5d and it somehow just doesn't fire my sigma flash for I don't know what reason... it also seems to have problems with my metz MZ 76 (all images overexposed). I tested both flashes out on my old 5d and it seems, they work perfectly fine? I'm confused, anybody who is having the same problems... any clues? Is my copy of the camera broken (hot shoe problems) or has Canon pushed the other guys out of business by just allowing E-TTL 2 or something?

Thanks in advance.


Logged

jani

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1624
    • yet
5d mk II and Sigma 500 DG SUPER Flash
« Reply #1 on: December 27, 2008, 03:21:41 pm »

Quote from: palmerson
Hey All. I just picked up my copy of the new 5d and it somehow just doesn't fire my sigma flash for I don't know what reason... it also seems to have problems with my metz MZ 76 (all images overexposed). I tested both flashes out on my old 5d and it seems, they work perfectly fine? I'm confused, anybody who is having the same problems... any clues? Is my copy of the camera broken (hot shoe problems) or has Canon pushed the other guys out of business by just allowing E-TTL 2 or something?
A bit of quick googling for sigma 500 dg super flash canon 5d mk ii should have told you that the problem is fairly well-known by Sigma flash users, also for the EOS 50D. This thread on Fred Miranda's forums should be particularly elucidating.

Sigma made an announcement in October regarding the problem with the 50D, but has yet to make a similar announcement for the 5D MkII.
Logged
Jan
Pages: [1]   Go Up