Pages: [1]   Go Down

Author Topic: Nikon D850 Tether Issue  (Read 393 times)

fpoole

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 57
    • http://www.frankpoole.com
Nikon D850 Tether Issue
« on: September 21, 2021, 02:03:58 pm »

I never had a problem tethering my Nikon D850 to various Mac computers.  Has always been solid until today. Running Capture One 21.

Out of nowhere I canít get the camera to connect to any computer now.  An Apple system warning pops up saying:
"USB Accessories Disabled. Unplug the accessory using too much power to re-enable USB devices."  This is a new one for me.

I tried different cables and even ran them through a powered Thunderbolt hub on a MacBook.  Same message Iím getting on my Desktop machine.  I know when the battery is very low it will disconnect but that is not the case here. 

It all worked fine yesterday and as far as I know nothing changed today.

Has anyone ever had this problem?  Is there something really simple Iím missing??  Since I never had this problem before Iím thinking itís the connector on the camera.  Will have to check with another camera body.

Frank Poole
Pages: [1]   Go Up