Pages: [1]   Go Down

Author Topic: latest LR fix  (Read 1522 times)

zobelaudio

  • Full Member
  • ***
  • Offline Offline
  • Posts: 127
    • zobeleye.com
latest LR fix
« on: March 16, 2021, 04:12:07 am »

Hi guys,

I'll start this topic here to share for people who've had this horrific LR bug and couldn't update to 10 without having to work with the superslow 10 updates until now.
I am quite reluctant to update again, since my LR was completely unusable with version 10, so I have only worked in 9.4 since nov.
I know this did not apply for everybody, but we the "few", who were actually a couple of thousands were quite frustrated and the forums were buzzing and not always in the nicest of ways...
So please feel free to share what's happening with the new update

cheers,
Stephan
Logged

mcbroomf

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1268
    • Mike Broomfield
Re: latest LR fix
« Reply #1 on: March 16, 2021, 05:23:55 am »

I'm not sure this is much help as I did not have any problems with the previous version, but I just updated to the new rev.  I was looking forward to it to get support for Sony A1 files.  No issues so far.

Win 10, huge cat ...

Mike
Logged

zobelaudio

  • Full Member
  • ***
  • Offline Offline
  • Posts: 127
    • zobeleye.com
Re: latest LR fix
« Reply #2 on: March 16, 2021, 07:59:40 am »

Ok, so the scrolling lag and the overall slowness seems to be gone.
But the fullview functionality is still an absolute mess.
I have to admit my files are big( GFX100)raws, but going into F>fullview, zooming in an unpreviewed file takes 27seconds, while in develop it takes between 5 and 10.
Still quite erratic, when going from G to F sometimes takes 17 sec even with an 1:1 previewed file.
And going out of it can also take up to 27 sec with the ball spinning. So no more casual, "oh I could edit or look at this file" but always create 1;1 previews before checking through older folders that have lost their previews. And btw this is not just for the 100mp files.
At least I have color grading now...I should rejoice
Logged

Chris Kern

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1811
    • Chris Kern's Eponymous Website
Re: latest LR fix
« Reply #3 on: March 16, 2021, 10:16:21 am »

The bug that caused performance degradation on systems with custom display profiles running Apple's MacOS apparently has been resolved.

As usual, Victoria Bampton has published an excellent summary of the publicly-announced changes in the new release.

Quote
This release has addressed a number of performance issues that came for a variety of users in 10.0 and 10.1. GPU usage and general performance bugs have been corrected. Our testing has been very positive on the success of the changes, and Adobe have taken longer than usual to correct as many known issues as possible.

We have a couple of forum participants who presumably have also been testing this latest rev and hopefully they will chime in if there is anything they are able to add.

(Personally, I've installed the upgrade on an Apple laptop I use for testing, but I think I'll wait a couple of days for the dust to settle before making any changes to my primary desktop machine.)

digitaldog

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 19213
  • Andrew Rodney
    • http://www.digitaldog.net/
Re: latest LR fix
« Reply #4 on: March 16, 2021, 11:54:14 am »

No issues on Mac and any version of V10.
Despite “all” the posts all over the web, this was a rare bug and it's fixed.
Update, update conservatively (roll back plan) or don't update. Your call alone.
Logged
Author “Color Management for Photographers" & "Photoshop CC Color Management" on pluralsight.com

Rand47

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1800
Re: latest LR fix
« Reply #5 on: March 16, 2021, 12:16:12 pm »

I had performance issues that “appeared” at one of the recent updates.  E.g. clone tool was agonizingly slow.  Turns out it wasn’t LrC at all, but out of date Nvidia drivers.  The only way I discovered this was when the latest Photoshop wouldn’t even allow edits and gave me a general error message.  Finally up popped an error message in Photoshop that mentioned video card issues.  I updated the video drivers and not only did Photoshop “work” - but the issues with LrC disappeared as well.  E.g. the clone tool is now instantaneous as it used to be.

For what it’s worth.

Rand
Logged
Rand Scott Adams

zobelaudio

  • Full Member
  • ***
  • Offline Offline
  • Posts: 127
    • zobeleye.com
Re: latest LR fix
« Reply #6 on: March 16, 2021, 12:28:23 pm »

hey Rand, that's interesting and you're the first one to mention this...I'll check
Logged

simon.garrett@iee.org

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: latest LR fix
« Reply #7 on: March 16, 2021, 03:06:32 pm »

Well, I'm not about to defend Adobe, as the performance of LR has not been great.  Even with v10.2, on starting the program there's time to learn a new foreign language to fluency while it starts up. 

On the new version (10.2) and a PC with AMD 3900X processor, going to a 36Mpixel raw with no preview, going from grid to full view, and then immediately clicking it to zoom in, it's about 4 seconds until the zoomed-in view is fully rendered (and "loading..." disappears).  Scrolling through images in grid view is faster... at the moment. 

What I've found in the past (pre 10.2) is that it may work fast, and then get into a state where scrolling from one image to the next takes several seconds.  Optimising the catalog several times in a row, exiting LR each time, can speed things up.  That's with a catalog of just under 80,000 images.
Logged

red2

  • Newbie
  • *
  • Offline Offline
  • Posts: 32
    • http://
Re: latest LR fix
« Reply #8 on: March 20, 2021, 11:02:16 am »

I just did the upgrade. Haven't tried much with the new version, but launch of the program was faster than with the previous version, and scrolling in Library mode was much improved vs. previous version.
I'm on a mid-2010 mac pro, 3.3 GHz 6-core Intel Xeon, 48 GB RAM, Radeon RX 580 8 GB graphics card, running OS X 10.14.6.
So at this point, after minimal investigation,  it looks much better.
Logged
Regards,
Bob D.

Idololab

  • Full Member
  • ***
  • Offline Offline
  • Posts: 202
    • http://WWW.IDOLOLAB.GR
Re: latest LR fix
« Reply #9 on: March 29, 2021, 04:51:56 am »

I just did the upgrade. Haven't tried much with the new version, but launch of the program was faster than with the previous version, and scrolling in Library mode was much improved vs. previous version.
I'm on a mid-2010 mac pro, 3.3 GHz 6-core Intel Xeon, 48 GB RAM, Radeon RX 580 8 GB graphics card, running OS X 10.14.6.
So at this point, after minimal investigation,  it looks much better.

Witch version of Lightroom please?
Logged
George Marinos
http://www.idololab.gr/
Fine art Photolab
Athens,Greece

red2

  • Newbie
  • *
  • Offline Offline
  • Posts: 32
    • http://
Re: latest LR fix
« Reply #10 on: March 29, 2021, 11:19:46 am »

Witch version of Lightroom please?

Currently using 10.2 of Lightroom Classic
Logged
Regards,
Bob D.

mshea

  • Full Member
  • ***
  • Offline Offline
  • Posts: 226
Re: latest LR fix
« Reply #11 on: March 30, 2021, 10:53:27 am »

I'm currently running OS V. 11.2 and LR 10.2. Performance was a bit slow, but usable, up until today. Uploading in the Develop module often takes over a minute; uploading TIFFs takes longer. Exporting a raw file as a small JPEG will take up to a minute and now RAWs and TIFFs won't transfer to PS ("The file could not be edited because Adobe Photoshop 2021 could not be launched.")

Update: a TIFF file finally transferred and opened in PS after a five minute wait.
« Last Edit: March 30, 2021, 11:17:05 am by mshea »
Logged

RahulRT

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
Re: latest LR fix
« Reply #12 on: March 31, 2021, 02:35:39 am »

Make Sure You're Running the Latest Version of LR fix
Logged
Pages: [1]   Go Up