Pages: [1]   Go Down

Author Topic: Damaged  (Read 556 times)

stamper

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 5861
Damaged
« on: August 24, 2019, 11:29:01 am »

My lumix gx7 camera has developed a problem. When I look at the Lcd the top half of the screen is black and the bottom white and an image I take looks the same. The camera functions, exposure, focus etc is OK. Changed the lens,battery and card to no avail. I take it that the sensor is fried?
« Last Edit: August 24, 2019, 11:38:08 am by stamper »
Logged

langier

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1241
    • Celebrating Rural America, the Balkans and beyond
Re: Damaged
« Reply #1 on: August 24, 2019, 04:55:24 pm »

Can't tell you what the problem is...however, the last time I sent a GX7 to the OEM for a minor repair, holy smoke, they wanted to fix some obtuse problem with the sensor that was higher than three figures, offering me another model as a refurb for about half the repair cost. Needless to day, the camera became a back-up and I simply went to eBay for another GX7 for less than what they offered to charge me for another model.

Unfortunately, I'm afraid it's the same with other m43 models for repairs in my experience. Best bet if you like your GX7, go to eBay and replace it or upgade to the newer GX8. Less expensive, time wasted and frustration with it all, IMO! :-)
Logged
Larry Angier
ASMP, ACT, & many more! @sacred_icons, @thirty9co
https://angier-fox.photoshelter.com

scooby70

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 487
Re: Damaged
« Reply #2 on: August 24, 2019, 06:25:43 pm »

My lumix gx7 camera has developed a problem. When I look at the Lcd the top half of the screen is black and the bottom white and an image I take looks the same. The camera functions, exposure, focus etc is OK. Changed the lens,battery and card to no avail. I take it that the sensor is fried?

You mention the LCD but what's the EVF look like?
Logged

mcbroomf

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1036
    • Mike Broomfield
Re: Damaged
« Reply #3 on: August 25, 2019, 06:50:53 pm »

My lumix gx7 camera has developed a problem. When I look at the Lcd the top half of the screen is black and the bottom white and an image I take looks the same. The camera functions, exposure, focus etc is OK. Changed the lens,battery and card to no avail. I take it that the sensor is fried?

If the camera functions OK as you say and the files are OK (not looking like the LCD) then it's just the LCD itself.
Logged

stamper

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 5861
Re: Damaged
« Reply #4 on: August 26, 2019, 04:00:52 am »

Thanks for the replies. I took the lens off and looked at the sensor. There was two black bits of plastic over the sensor which looked like the shutter mechanism. I pushed them down and I have engaged the electronic shutter which should "solve" the problem. Yet to try it out and I believe that at shutter speeds above 500th/sec blurring could be a problem with fast moving objects. Time will tell.
Pages: [1]   Go Up