Pages: [1]   Go Down

Author Topic: H3DII back LED flashing  (Read 242 times)

GeekAndProud

  • Newbie
  • *
  • Offline Offline
  • Posts: 6
H3DII back LED flashing
« on: June 10, 2019, 05:42:07 pm »

Up until today my H3DII-31 was working fine, upon inserting the battery now the LED on the back flashes red and refuses to start.

Anyone got any ideas as to what's going on and if anywhere still services these older generation cameras?
Logged

BobShaw

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1530
    • Aspiration Images
Re: H3DII back LED flashing
« Reply #1 on: June 10, 2019, 06:55:31 pm »

What LED?
Try removing the back from the body and cleaning the contacts.
If you can borrow another camera try determine if it is the back or the body (or the battery).
Hasselblad will service them but the cost is usually beyond the value.
You can use an H3D-II back on an H4 body and gain the advantage of True Focus.
Logged
Website - http://AspirationImages.com
Fine Art Photography

GeekAndProud

  • Newbie
  • *
  • Offline Offline
  • Posts: 6
Re: H3DII back LED flashing
« Reply #2 on: June 10, 2019, 07:12:39 pm »

The status LED on the back which usually shows card activity/back startup etc
Logged

Joe Towner

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1094
Re: H3DII back LED flashing
« Reply #3 on: June 12, 2019, 11:04:43 am »

Is there a CF card in it?  Pop the back off the body & attach it to a computer via firewire cable - does it do the same error?  +1 for Bob's recommendation on cleaning the contacts.

Is there a discernible pattern to the flashes?
Logged
t: @PNWMF
Pages: [1]   Go Up