Pages: [1]   Go Down

Author Topic: Sony A7 SD slot issue  (Read 1745 times)

PeterAit

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 4561
    • Peter Aitken Photographs
Sony A7 SD slot issue
« on: January 05, 2019, 11:17:08 am »

My A7Riii, about 6 months old, has a problem with SD slot 1 - the card won't stay in. Push it in and it just pops right back out. Slot 2 works fine. Has anyone experienced this? I suppose there is nothing I can do about it but send it in for warranty repair.

But, in the meantime, it seems I should be able to use the camera with a card in slot 2 only. But it does not seem possible.

Thanks.
Logged

Dave Rosser

  • Full Member
  • ***
  • Offline Offline
  • Posts: 228
    • My Website
Re: Sony A7 SD slot issue
« Reply #1 on: January 05, 2019, 01:21:21 pm »

My A7Riii, about 6 months old, has a problem with SD slot 1 - the card won't stay in. Push it in and it just pops right back out. Slot 2 works fine. Has anyone experienced this? I suppose there is nothing I can do about it but send it in for warranty repair.

But, in the meantime, it seems I should be able to use the camera with a card in slot 2 only. But it does not seem possible.

Thanks.
Had a similar problem on a brand new Fuji X-Pro 2 a few months ago, I just missed the 30 day return for refund or replacement period so it went back to Fuji for a warranty repair, they replaced the whole main board to which the SD card module is soldered. In my case the symptoms were not being able to save pictures without a card being in both slots and then not being able to write to slot 1.  Now the camera works with a card in slot 1 only as well as both slots.  (I can see no need at all for the second slot so don't want to use it anyway.)
Logged

E.J. Peiker

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 891
    • http://www.ejphoto.com
Re: Sony A7 SD slot issue
« Reply #2 on: January 05, 2019, 05:35:01 pm »

My A7Riii, about 6 months old, has a problem with SD slot 1 - the card won't stay in. Push it in and it just pops right back out. Slot 2 works fine. Has anyone experienced this? I suppose there is nothing I can do about it but send it in for warranty repair.

But, in the meantime, it seems I should be able to use the camera with a card in slot 2 only. But it does not seem possible.

Thanks.
There is a little spring loaded lock deep inside there.  yours has obviously broken, assuming this happens with more than one SD card.  It will need to be repaired.  Yes you can only shoot with slot 2 but that slot is UHS 1 only and a lot slower to write than slot 1 (assuming you are using UHS2 cards).
Logged

mcbroomf

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1542
    • Mike Broomfield
Re: Sony A7 SD slot issue
« Reply #3 on: January 05, 2019, 06:19:48 pm »

My A7Riii, about 6 months old, has a problem with SD slot 1 - the card won't stay in. Push it in and it just pops right back out. Slot 2 works fine. Has anyone experienced this? I suppose there is nothing I can do about it but send it in for warranty repair.

But, in the meantime, it seems I should be able to use the camera with a card in slot 2 only. But it does not seem possible.

Thanks.

Yes, this exact same thing happened to me (A7R3).  As I recall I used it on slot 2 for a while but you have to change the settings to write to slot 2 1st.  ie it will not cascade over to slot 2 if slot 1 is missing and is 1st choice.  In addition to changing Select Media on Shoot Mode/Drive 1 page 3, and Select PB Media on Playback 3 page 3 to Slot 2, you have to verify that Rec Media Setting is on Slot 2 (and I also turned off Auto Switch).  Setup 6 page 6/7

Sony fixed it for me within warranty and it also needed a full motherboard.  If you are a member of Sony Pro you can get a loaner from them.

« Last Edit: January 05, 2019, 06:38:35 pm by mcbroomf »
Logged
Pages: [1]   Go Up