Pages: [1]   Go Down

Author Topic: LR CC Classic doesn't read X100T lens metadata properly  (Read 345 times)

Mike D. B.

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1018
LR CC Classic doesn't read X100T lens metadata properly
« on: December 11, 2018, 08:44:30 am »

I just returned from a four day trip to Venice.  The camera I took was my favorite, the Fujifilm X100T with fixed 23mm lens.  Two auxiliary lens converters exist, but I don’t own them - they would change the focal length to 19 and 33mm.

Upon import of the raw files to LR CC Classic, I noticed that some images were being recoded as having been taken with a 19mm, others with a 33mm and some with the proper 23mm focal length lens.  This is shown in the metadata and falsely “corrects” when I enable profile corrections.  Post processing is complicated by the fact too.

I’ve never encountered this phenomenon before and and believe it to be a fault of LR, not the camera.  I haven’t changed any setting in the camera to warrant such a faulty reading of focal length.

Has anyone using a similar Fujifilm camera encountered this and how have you overcome the erroneous focal length readings?

I’ve just updated LR (today) to version 8.1 and had been running 8.0 when I first noticed this on my MacBook Air.  After importing the image catalog to my iMac, the same faulty metadata focal lengths remained.
Logged
Kind regards, Mike

kirkt

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 571
Re: LR CC Classic doesn't read X100T lens metadata properly
« Reply #1 on: December 11, 2018, 09:13:57 am »

Just a sanity check - take one of the files that is incorrectly identified in LR and open it in Preview and look at the metadata in the Inspector tool.  Is the focal length correct there?

Just a first check on the metadata outside of LR.

Kirk
Logged

Mike D. B.

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1018
Re: LR CC Classic doesn't read X100T lens metadata properly
« Reply #2 on: December 11, 2018, 10:00:16 am »

Good point, Kirk!  And the result is: it also shows the incorrect focal length!  I guess I'll reset the camera to factory settings and hope to have corrected the camera's hiccup.

Thanks for your suggestion, Kirk!
Logged
Kind regards, Mike

kirkt

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 571
Re: LR CC Classic doesn't read X100T lens metadata properly
« Reply #3 on: December 11, 2018, 03:14:43 pm »

You're welcome - funky error.

Kirk
Logged
Pages: [1]   Go Up