Pages: [1]   Go Down

Author Topic: EPSON P600 Drops of ink?  (Read 354 times)

Clark

  • Newbie
  • *
  • Offline Offline
  • Posts: 15
EPSON P600 Drops of ink?
« on: June 13, 2018, 10:08:02 AM »

Hi all, Iím using an Epson p600, and just had this come out on a print. Two drops of cyan on an otherwise perfect print.

Any of you recognise this problem?

A brief bit of possibly relevant info:

Iíve recently had to run quite a few head alignments and also cleaning cycles to fix a stubborn problem with the vlm head. I ran 4 cycles yesterday morning and another 2 in the evening, with quite a few test strips in between, followed by another one this morning which finally resulted in a perfect nozzle check.

I decided to resume normal printing, ran one through perfectly, then this.

Let me know your thoughts anybody.
Logged

Farmer

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2845
Re: EPSON P600 Drops of ink?
« Reply #1 on: June 13, 2018, 08:53:05 PM »

I suspect there's some detritus on the head - fibres or dust?
Logged
Phil Brown

Conner999

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 706
Re: EPSON P600 Drops of ink?
« Reply #2 on: June 14, 2018, 07:54:05 AM »

Our 3800 does this when there's excess ink/crap buildup trapping ink around the head, capping station and wipers. If you ran a lot of cleaning cycles that could have brought the issue to the fore faster,

Check Google for 'cleaning Epson 3800' to see what's involved (not big deal) and then see if able to do something similar for 600.
Logged
Pages: [1]   Go Up