Pages: [1]   Go Down

Author Topic: Issue with 645DF and PhaseOne 120 mm  (Read 155232 times)

djordjezivaljevic

  • Newbie
  • *
  • Offline Offline
  • Posts: 14
    • www.djordjezivaljevic.com
Issue with 645DF and PhaseOne 120 mm
« on: September 23, 2017, 01:11:07 pm »

Hi guys,

I hope I am posting this to the rignt part of this lovely forum. I recently bought a PhaseOne 120 mm macro lens. But something there isn't right. When I press shutter to take a photo, I can hear the mirror goes up, but than some buzzing appears, like camera trying to close the aperture blades of lens and mirror..so basically it gets stucked. Than I need to turn off back/camera, remove lens from body, turn on body so the mirror goes down. Aperture blades remain closed even they should be open...

All other Phase Lenses behave perfectly. This lens on other 645df body (previous owner) worked well... DB is P65+ .

Any suggestion?

I am not sure where to track issue...is it body, lens, or both...
Logged
www.djordjezivaljevic.com
Montenegro, Europe

Paul2660

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 4066
    • Photos of Arkansas
Re: Issue with 645DF and PhaseOne 120 mm
« Reply #1 on: September 23, 2017, 04:44:46 pm »

Besides a bad lens, you may just need firmware on the 120mm or Df or both. 

The DF will need the V grip for firmware, and the lens needs to be attached to the DF with the V grip for a firmware update.

Best to locate a P1 dealer in your geo as if it's firmware pretty much only a dealer can do this unless you have access to the V grip.

You might also move or re-post this in the MF forum.

Paul Caldwell
Logged
Paul Caldwell
Little Rock, Arkansas U.S.
www.photosofarkansas.com
Pages: [1]   Go Up