Pages: [1]   Go Down

Author Topic: Profoto TTL-N or C Air Remotes Cutting Off Unexpectedly  (Read 533 times)

DPPhoto

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
Profoto TTL-N or C Air Remotes Cutting Off Unexpectedly
« on: December 14, 2015, 09:59:55 am »

Has anyone else encountered problems with their Profoto TTL-N or C air remotes? My TTL-N remote cuts itself off at random intervals during shoots pretty much every time I use it. It has happened as quickly as 19 seconds after my most recent shot. One shot it was on, the next it was off. I'm using a Nikon D810. I've encountered the issue in both normal flash mode and rear curtain flash mode. This occurs with all of my B1 heads and my B2 pack. (It is the remote itself which cuts off, not the heads.) I've tried fresh batteries. I've updated the firmware. I've sent the remote to Profoto and they replaced it with a new one which has the same issue. The reps at Profoto tell me that I'm alone in this issue and that no one else has reported it. Does that mean it's my camera, (which by the way works just fine with all my Nikon flashes and Pocket Wizard units)? Is the problem just that I'm the only D810 owner who uses the TTL-N on earth? If anyone else has encountered an issue like this, it sure would be great to know about it, especially if you were able to get it resolved. This has been disastrous on several occasions when my flash units have not fired and I didn't realize it until later. It's been embarrassing to say the least when clients have asked me why the flash wasn't going off. They have no idea that I spared no expense on these units. Just that they are not working. Thanks!
Logged
Pages: [1]   Go Up