Pages: [1]   Go Down

Author Topic: OSX10.5, MacPro's and Epson?  (Read 4826 times)

jjlphoto

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 467
OSX10.5, MacPro's and Epson?
« on: December 11, 2008, 12:42:50 PM »

There have been some discussions about Leopard running on the Intel Macs. The Epson drivers have some issues with ICC profiles apparently? My MacPro is still on Tiger and want to sort out some issues before I upgrade.


Logged
Thanks, John Luke

Member-ASMP

Wayne Fox

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 3527
    • waynefox.com
OSX10.5, MacPro's and Epson?
« Reply #1 on: December 11, 2008, 12:48:38 PM »

I've been on Leopard since shortly after it was released, Epson has pretty much updated all drivers. Running a 3800, 11880 and 7900 with no problems.

  ( perhaps some of the older printers still have issues, not sure they are updating those drivers - 4000,76/9600).
Logged

jjlphoto

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 467
OSX10.5, MacPro's and Epson?
« Reply #2 on: December 11, 2008, 01:56:54 PM »

Quote from: Wayne Fox
I've been on Leopard since shortly after it was released, Epson has pretty much updated all drivers. Running a 3800, 11880 and 7900 with no problems.

  ( perhaps some of the older printers still have issues, not sure they are updating those drivers - 4000,76/9600).

Thanks Wayne. I use a 3800. One of my contacts mentioned that his PPC Macs made the Leopard transition fine with printing on his 4800's, but for some reason he was still having glitches printing with his Intel Macs and Leopard. Good to hear it has been addressed. I guess some Intel Macs are still having some wireless issues if running Leopard.




Logged
Thanks, John Luke

Member-ASMP

sesshin

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 94
    • http://
OSX10.5, MacPro's and Epson?
« Reply #3 on: December 11, 2008, 06:08:51 PM »

I have three Epson wide format printers too and run os x 10.5 on a Mac Pro with zero problems.
Logged

digitaldog

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 11895
    • http://digitaldog.net/
OSX10.5, MacPro's and Epson?
« Reply #4 on: December 11, 2008, 06:56:06 PM »

Quote from: sesshin
I have three Epson wide format printers too and run os x 10.5 on a Mac Pro with zero problems.

Zero here as well other than the Advanced B&W, where, with CS4, you need to setup Photoshop Manages Color and select Adobe RGB (1998) as the "printer" profile. Printer Manages Color seems to work as well, I just stay way from that mode of printing.
Logged
Andrew Rodney
Author “Color Management for Photographers”
http://digitaldog.net/

Jack Flesher

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2592
    • www.getdpi.com
OSX10.5, MacPro's and Epson?
« Reply #5 on: December 11, 2008, 08:17:58 PM »

Quote from: sesshin
Epson wide format printers too and run os x 10.5 on a Mac Pro with zero problems.

Ditto here --- no issues whatsoever.  
Logged

jjlphoto

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 467
OSX10.5, MacPro's and Epson?
« Reply #6 on: December 12, 2008, 09:37:23 AM »

Thanks for all the great replies!
Logged
Thanks, John Luke

Member-ASMP

na goodman

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 388
OSX10.5, MacPro's and Epson?
« Reply #7 on: December 12, 2008, 10:26:28 AM »

I concur with everyone else. Running a 3800, 9800 and 9880 - no problems at all.
Logged

josephchiang

  • Newbie
  • *
  • Offline Offline
  • Posts: 6
OSX10.5, MacPro's and Epson?
« Reply #8 on: December 15, 2008, 03:13:47 AM »

Has anyone had any luck finding a solution for printing to the x600 series Epson Prographics printers from Leopard?
Logged

na goodman

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 388
OSX10.5, MacPro's and Epson?
« Reply #9 on: December 15, 2008, 08:35:41 AM »

So, are you saying you did download the leopard driver for the x600 and it is not working?
Logged
Pages: [1]   Go Up