Pages: [1]   Go Down

Author Topic: Hasselblad H4D-40 With Speedlight on Hot shoe...Cant set Shutter speed  (Read 406 times)

rollsman44

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 629

I set the camera to manual Mode and i am able to change the Shutter speed and Aperture.
   When I mount my Flashpoint speedlight on the Hot shoe and set the camera to manual. I adjust the aperture but the shutter speed goes into seconds and cant set it to 1/60 or anything only seconds.  Is it my flash thats Not compatible?
   Also, if I set my camera to Aperture priority the camera will set the correct shutter speed. Weird or ???   Thank you
Logged

BobShaw

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2157
    • Bob Shaw Photography
Re: Hasselblad H4D-40 With Speedlight on Hot shoe...Cant set Shutter speed
« Reply #1 on: December 08, 2020, 04:48:35 pm »

As a starting point, have your reset the camera to Default? (Profiles / Standard / Load)
Are the three firmwares versions of Body, Mag and Viewfinder the current ones? (System Status)
Does the internal flash work correctly with no external flash?

Any flash unit should work on manual mode AFAIK, however Hasselblad warns against it in big red letters.
I guess the question is why would you put a hot shoe external flash on a Hasselblad (:-)
Logged
Website - http://BobShawPhotography.com
Studio and Commercial Photography

Joe Towner

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1359
Re: Hasselblad H4D-40 With Speedlight on Hot shoe...Cant set Shutter speed
« Reply #2 on: December 11, 2020, 12:21:11 am »

Is the Flashpoint a TTL flash or a single, center pin manual flash?

A non-ttl adapter like https://neewer.com/products/camera-speedlite-flash-10036052 would work.
Logged
t: @PNWMF
Pages: [1]   Go Up