Pages: [1]   Go Down

Author Topic: Need new PSD  (Read 2609 times)

Tim Gray

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2002
    • http://www.timgrayphotography.com
Need new PSD
« on: December 11, 2005, 02:33:02 PM »

Time for a new PSD - anyone have direct experience with Hyperdrive?  I'm thinking of getting this with a 100gb drive - I don't think I'd get the drive much cheaper separately.  I was also considering the Nexto CF, but I prefer the HD80:

AA battery format
Don't need firewire to upgrade the firmware
Seems to have better option for verification (may be wrong here, though)
North American distribution
Logged

Andrew Larkin

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 85
Need new PSD
« Reply #1 on: December 12, 2005, 12:36:08 AM »

Tim,

I downloaded the user manual for the HD80 and went through it in detail.

I agree that the HD80 does appear to be a better overall device than the Nexto, as long as it lives up the specs and general build quality.

I bought one Nexto (which has had problems) and had planned to buy a second up until the problems.  I think this second purchase will be the HD80 as the cost will be about the same.

Andrew
Logged

Tim Gray

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2002
    • http://www.timgrayphotography.com
Need new PSD
« Reply #2 on: December 12, 2005, 08:51:35 AM »

thanks...
Logged

erichK

  • Newbie
  • *
  • Offline Offline
  • Posts: 20
Need new PSD
« Reply #3 on: January 01, 2006, 06:41:58 PM »

What problems did you have with your NexTO?  I have almost 20GB of Galapagos images on mine, all of them loaded quickly and smoothly. Am shocked to find our twin CPU Powermac G4, running OS 10.3.9 would not complete booting with the NextTO plugged in either through USB or Firwire, and that it would not come up on the desktop when I attmpted to mount it later. The system profiler and disk utility also did not help: just went into eternal spin.

Am also puzzled. because it seemed to work fine, when I tested it briefly before I left and because it seems to mount fine, using USB, on out PC.

erichK
saskatoon, canada
Logged
Pages: [1]   Go Up