Pages: [1]   Go Down

Author Topic: 2200 Dead ???  (Read 6865 times)

ron ritcher

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 96
2200 Dead ???
« on: October 03, 2005, 10:23:31 PM »

Oops . . . during a recent move, my 2200 fell from its table onto the carpeted floor.  No visible damage, save part of the feed area in back needed to me snapped back into place.  Set everything up here at the new digs, fired it all up, and after the usual grunting and groaning, all the ink light and the paper-feed light began flashing red.  My manual referred me to the paper-cutter installation page -- but I've never used it, and can't really see how that applies.

Ok, so did the fall kill her?  Any suggestion and/or words of encouragment?  Thanks in advance!

--Ron
Logged

giles

  • Full Member
  • ***
  • Offline Offline
  • Posts: 209
2200 Dead ???
« Reply #1 on: October 03, 2005, 11:52:38 PM »

For any electical gear that is unhappy after a move, I would check that everything inside is properly connected. Vibration during transit can sometimes cause things to work loose, as could being dropped!

If you do this, please use care.  Some equipment retains dangerous even when unplugged from the mains.

Good luck,

Giles
Logged

ron ritcher

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 96
2200 Dead ???
« Reply #2 on: October 04, 2005, 01:05:40 AM »

Thanks, Giles, but I'm not comfortable prowling around inside -- nor would I likely be able to recognize any electrical problems.  (But I appreciate the reply!)

Anyone out there ever have the "red lights flashing" experience -- and if so, what, short of the county dump, was the solution?  Thanks . . .

--Ron
Logged

Jonathan Wienke

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 5829
    • http://visual-vacations.com/
2200 Dead ???
« Reply #3 on: October 04, 2005, 01:08:08 AM »

Call Epson for service?

ron ritcher

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 96
2200 Dead ???
« Reply #4 on: October 04, 2005, 12:32:07 PM »

Probably good advice, Jonathan . . . BUT anecdotal evidence around here suggests that the Epson support services are nightmarish, AND when I dialed their tech # (the one listed in my 2200 manual), I got a REALTY OFFICE somewhere!

I WILL follow-through with Epson, but was/am hoping somebody here at LL can shed light on this particular issue . . .  Thanks.

--Ron
Logged

Steven M Anthony

  • Newbie
  • *
  • Offline Offline
  • Posts: 47
    • www.smaphoto.com
2200 Dead ???
« Reply #5 on: October 04, 2005, 03:27:54 PM »

Maybe the fall moved something near where the paper cutter attaches--making it "think" the paper cutter should be attached.  Just a guess.
Logged
Steve

http://www.smaphoto.com/

Canon 10D
Tamron 28mm - 300mm
Epson R2400

kbolin

  • Full Member
  • ***
  • Offline Offline
  • Posts: 227
    • http://www.bolinphoto.com
2200 Dead ???
« Reply #6 on: October 05, 2005, 01:42:44 AM »

I wish mine would crash... then it would give me good reason to buy the new 4800.
::

ron ritcher

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 96
2200 Dead ???
« Reply #7 on: October 05, 2005, 11:19:55 AM »

Hey, kbolin--

It's simple:  trade me yours for mine, tinker with the DOA one for awhile, then throw up your hands in disgust and swear off the lousy thing . . . and buy your new 4800, assured that you did everything in your power to revive the poor, departed 2200!

But, seriously, thanks to all who replied, and I'll leave with one, final question:  HAS ANYONE CONFRONTED THE "ALL INK-LIGHTS PLUS PAPER LIGHT FLASHING" MODE???  And, if so, what was the solution?  Gracias . . .

--Ron
Logged

Jonathan Wienke

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 5829
    • http://visual-vacations.com/
2200 Dead ???
« Reply #8 on: October 05, 2005, 11:25:52 AM »

Quote
Probably good advice, Jonathan . . . BUT anecdotal evidence around here suggests that the Epson support services are nightmarish, AND when I dialed their tech # (the one listed in my 2200 manual), I got a REALTY OFFICE somewhere!
I called them once, got Epson, and spoke to a service tech who obviously spoke English as a first language, and solved my problem in under 3 minutes. Total call duration was under 5 minutes. I don't have the number I called handy, though.

DiaAzul

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 777
    • http://photo.tanzo.org/
2200 Dead ???
« Reply #9 on: October 05, 2005, 05:21:35 PM »

Do you have the paper cutter attachment. If so, I suggest that you install it, switch the printer on and off (cylce it through the power up/down cycle) a couple of times and see if it clears the error. It could be that something mechanical has become latched up/down or that a software setting has got tripped into an unidentified mode.

Failing the above, disconnect the printer from the power and gently with a plastic spatula or, if you are feeling more confident, a screwdriver depress the latches and catches and move and moving bits associated with the paper cutter to ensure that they can go through a full range of movement. Reconnect and switch on and off a couple of times.

It's probably also worth giving it a good wipe with a damp cloth and ensure that there is no dust clogging the works.

Last stop is calling in a dealer (though probably cheaper to by a new chassis - the cost of printing is actually in the inks).

Espon 2100 (Euro version of 2200) is here http://support2.epson.net/manuals....E_1.HTM
Logged
David Plummer    http://photo.tanzo.org/

ron ritcher

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 96
2200 Dead ???
« Reply #10 on: November 10, 2005, 01:47:58 PM »

THANKS to all of you who replied!  Here's how it turned out:

At Epson's suggestion, I took the 2200 to a nearby service center; they charged me $25, but couldn't find any problem (other than it wouldn't work!); they offered to send it back to Epson in Indianapolis for a $175 fix;  three weeks later, it's back in great shape, having had a print head replaced.  All in all, I feel fortunate to have spent relatively little time and expense to get "back in the saddle."  Thanks, again for those who chimed-in . . .

--Ron
Logged

Eric Myrvaagnes

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 11076
    • http://myrvaagnes.com
2200 Dead ???
« Reply #11 on: November 10, 2005, 09:42:36 PM »

Quote
THANKS to all of you who replied!  Here's how it turned out:

At Epson's suggestion, I took the 2200 to a nearby service center; they charged me $25, but couldn't find any problem (other than it wouldn't work!); they offered to send it back to Epson in Indianapolis for a $175 fix;  three weeks later, it's back in great shape, having had a print head replaced.  All in all, I feel fortunate to have spent relatively little time and expense to get "back in the saddle."  Thanks, again for those who chimed-in . . .

--Ron
[a href=\"index.php?act=findpost&pid=50961\"][{POST_SNAPBACK}][/a]
Ron,

Thanks for the update. Since I first heard your horror story, I've been very nervous about my 2200. I hope yours and mine both live long and useful lives.

Eric
« Last Edit: November 11, 2005, 03:33:41 PM by EricM »
Logged
-Eric Myrvaagnes

http://myrvaagnes.com  Visit my photo website. New images each season. Also visit my new website: http://ericneedsakidney.org

drew

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 477
    • http://www.andrewrichards.net
2200 Dead ???
« Reply #12 on: November 11, 2005, 10:30:21 AM »

I have a continuous inking system for my 2100 and I get the all lights flashing whenever the carriage is obstructed. The same is also true if you power up a 7600 first time with the head locking device still in situ. If you get this happening with a 2100/2200, when you first power it up, pull the power lead out a soon as the head disengages from its start position on the right hand side. This unlocks the head and allows you to slide it back and forward to see if there is any obstruction. Other than this, the all-flashing lights is I think I think a more generic warning of a serious problem and I very much doubt it is attributable to the cutter.
Logged
Andrew Richards My Webpage

Robt

  • Newbie
  • *
  • Offline Offline
  • Posts: 15
2200 Dead ???
« Reply #13 on: November 14, 2005, 12:29:51 AM »

I have had some problems with the 2200 lately and I think I have found a repair solution that is affordable and works.

I'm in Seattle and when mine [2200] went down I started calling the good electronics repair shops I knew of.  Time after time I was told it was not feasible to try to fix ink jets until one of them told me that Epson has a program that the vendor can send the printer to them and they will fix it - no matter what is wrong for a flat rate.  The vendor I used in Seattle happened to be the Apple Store.

Cost me $180 including sales tax plus about $15 in shipping.  It came back with many [not all] of its problems intact.  I made a print with it that had over half the colors missing then made a copy of the image on an hp officejet to show them that, yes Mt. Baker does have green trees in addition to the cyan ones the printer showed.

Got it back,  all new heads, new paper feed, and returned 'my' ink cartridges.  I think the ink jet cartridges were a help because with out them they had something to blame the problems on.

You might call Epson and find out who are their vender's for such things.  Do shop all of the vender's because I found the price varied about 35-40 bucks.

Good luck
Logged
Robert Collins
Seattle
Pages: [1]   Go Up