Pages: [1]   Go Down

Author Topic: Mac Pro 2013 - 10.9.3 - latest C1 Pro - disaster...  (Read 1785 times)

BernardLanguillier

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 10643
    • http://www.flickr.com/photos/bernardlanguillier/sets/
Mac Pro 2013 - 10.9.3 - latest C1 Pro - disaster...
« on: May 24, 2014, 06:03:37 PM »

Trying to use any form of GPU acceleration on the latest C1 Pro on top of 10.9.3 on the D700 equipped Mac Pro 2013 results basically in a complete freeze of the system.

This is a further regression introduced by 10.9.3, in 10.9.2 using Auto GPU for display was ok.

Disaponting from Apple and Phase 1.

It seems that Apple is unable to release stable drivers for the D700 6 months after availability and/or that Phase1 may need some Open CL focus.

Cheers,
Bernard
« Last Edit: June 04, 2014, 04:18:54 AM by BernardLanguillier »
Logged
A few images online here!

Another Paul

  • Newbie
  • *
  • Offline Offline
  • Posts: 4
Re: Mac Pro 2013 - 10.9.3 - latest C1 Pro - disaster...
« Reply #1 on: May 27, 2014, 11:41:28 PM »

I too have turned off GPU acceleration on a Mac Pro 2013 with D700s. Considering that other vendors are having difficulty and Phase One's earlier leading support for GPUs, it is pretty clear that the problem lies with the Fruit Company. Were the Mac Pro another product in a different industry, the Fruit Company would be in a lot of contract trouble by now.

-- Paul
Logged

lkuhlmann

  • Newbie
  • *
  • Offline Offline
  • Posts: 33
Re: Mac Pro 2013 - 10.9.3 - latest C1 Pro - disaster...
« Reply #2 on: May 28, 2014, 01:24:00 AM »

As a developer I can only confirm this problem lies at Apple. At Phase One we have extreme focus on OpenCL usage especially for Mac Pro D700 systems. We are in dialog with Apple, but they have failed to solve the problem as of yet.
PS also turns off OpenCL acceleration for 10.9.3 http://macperformanceguide.com/blog/2014/20140116_7-MacPro2013-PhotoshopCC-GPU-sharpening.html

-Lionel
Logged

BernardLanguillier

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 10643
    • http://www.flickr.com/photos/bernardlanguillier/sets/
Re: Mac Pro 2013 - 10.9.3 - latest C1 Pro - disaster...
« Reply #3 on: June 04, 2014, 04:19:52 AM »

As a developer I can only confirm this problem lies at Apple. At Phase One we have extreme focus on OpenCL usage especially for Mac Pro D700 systems. We are in dialog with Apple, but they have failed to solve the problem as of yet.
PS also turns off OpenCL acceleration for 10.9.3 http://macperformanceguide.com/blog/2014/20140116_7-MacPro2013-PhotoshopCC-GPU-sharpening.html

-Lionel

Thanks for the input Lionel. I cannot say I am surprised.

Cheers,
Bernard
Logged
A few images online here!
Pages: [1]   Go Up