Pages: [1]   Go Down

Author Topic: "Assertion Failed" dialog after installing Lr 5.4  (Read 1866 times)

WernerG

  • Newbie
  • *
  • Offline Offline
  • Posts: 14
"Assertion Failed" dialog after installing Lr 5.4
« on: April 22, 2014, 08:48:49 AM »

I upgraded to 5.4 yesterday on my Win 7 64 bit.  Lr 5.4 wouldn't open, showing a dialog that said "assertion failed".  I googled the error along with Lightroom 5.4 and found quite a lot of chatter about it.  None of the fixes recommended worked.  One suggestion was to run Lr "As Administrator", the other was to remove the Preferences file and let Lr rebuild it.  Neither worked.

I went back to Lr 5.3 and it works fine. 

I searched the error here and haven't found any comments about it, at least not recently.  It appears to be primarily Win 7/64 users that are getting the error.  Has anyone else experienced it?
Logged

Simon Garrett

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 628
Re: "Assertion Failed" dialog after installing Lr 5.4
« Reply #1 on: April 22, 2014, 09:12:28 AM »

See http://helpx.adobe.com/lightroom/kb/lightroom-error-assertion-failed-update.html

Also have a look on http://forums.adobe.com/community/lightroom?view=discussions, as quite a few threads discussed this problem. 

I didn't get that problem, so I didn't read what the solution was, but doing a search found loads of posts on that forum: http://forums.adobe.com/community/search.jspa?peopleEnabled=true&userID=&spotlight=false&containerType=14&container=3316&rankBy=date&q=assertion+failed
Logged

john beardsworth

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 3494
    • http://www.beardsworth.co.uk
Re: "Assertion Failed" dialog after installing Lr 5.4
« Reply #2 on: April 22, 2014, 09:14:29 AM »

You'll find a lot of vague chatter because "assertion failed" is a very broad error message that doesn't help anyone. I don't think it's really more of a Windows thing, and preference files are more often a problem on Mac.

It tends to be related to plug-ins. Do you have any installed? Are any plug-ins installed in C:\Users\YOU\AppData\Roaming\Adobe\Lightroom\ ? Other things in this folder may also be causing a problem, so you might try renaming it and then restarting LR.

John

WernerG

  • Newbie
  • *
  • Offline Offline
  • Posts: 14
Re: "Assertion Failed" dialog after installing Lr 5.4
« Reply #3 on: April 22, 2014, 10:22:57 AM »

Thanks for the links.  I saw the "fix" that requires messing about in the Registry; not me.  Besides, My Pictures folder is in its default location.   5.4 doesn't do much for me since my cameras and lenses are all covered in 5.3.  I was hoping to load some downloaded test raw files for some of the recent cameras releases but I can wait until Adobe gets 5.4 fixed.
Logged
Pages: [1]   Go Up