Pages: [1]   Go Down

Author Topic: Use of DNG Camera Calibration Profile Blocks "Edit Inů" Functionality Weirdness  (Read 621 times)


  • Jr. Member
  • **
  • Offline Offline
  • Posts: 90

Came across a weird issue yesterday when working in LR 5.2 on some old (2011) files taken with my Leica M8 and trying to open some in PSCS6, using the Photo > Edit inů routine.

Some files this worked fine, but a lot it did not. Hitting Photo> Edit inů created a nil response from LR, and the files were not sent to PS, or to any of the other apps like DxO ViewPoint I have set up as external editors in LR. The problem did not arise with TIFF's, or with  ff.dng files generated by the Flat Field plug-in, just to some of the M8 .DNG files.

To cut a long story (c. 20 hours of head-scratching, purging out plugins, rebooting, running Disk Utility, trying in LR4 on my own and my wife's machine, etc, etc) short, it seems that those of my M8's DNG files which would not open into PS from LR5.2 were those to which I had added Camera Calibration settings generated by the DNG Profile Editor, my "M8 Daylight Profile" settings based on processing an M8 DNG shot of a Macbeth Colour Checker card. The same files worked fine with Photo> Edit Inů when I cranked up my old LR version 4.4 and tried it, but in LR 5.2 no M8 DNG file with my "M8 Daylight Profile" setting under Camera Calibration would support the Photo> Edit in.. command.

I have a few thousand such files in my Library, and as I like the colour of these files in general better than those with any of the standard Adobe camera profiles, I'm going to keep them as they are, rather than trawl through for them and amend them all (which would be easy once I'd identified them, of course). As it is, if I find others I want to do work on in PS in the future, I'll have to change the calibration settings and re-work tone and HSL as appropriate, but I'm posting this here for these reasons:

1: as a follow-up to my previous post of last July, which I suspect with hindsight now was the same problem, though I missed out on recognising it was an issue only fro some specific files at that time

2: in case it might save a lot of times for someone else who finds they have this problem 

3: to see if anyone here can explain how  this can happen

Look forward to any suggestions what's gone wrong here, or how to fix it (no longer have the M8, so I can't rebuild the profile and sneak a new one in to fool LR). It does seem odd the profile continues to support the "Edit inů" routine in LR4, but blocks it in LR5  ???


PS : I'm running LR under Lion 10.7.5 on an ageing  2006 Intel Mac Pro
Pages: [1]   Go Up