Pages: [1]   Go Down

Author Topic: problems with smart folders/keywords  (Read 12421 times)

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
problems with smart folders/keywords
« on: August 25, 2013, 10:56:15 PM »

Has anyone noticed problems with smart folders not selecting all images with a specified keyword?  I'm using a single catalog and have keyworded approx. 90 images with a single keyword.  I then created a smart album to select all images in the catalog with that keyword.  The result is the album finds a handful of the images and no more.  I've been round and round with PhaseOne support - they had me verify/repair the catalog, and even start over with a fresh new catalog.  The result is the same - a smart album looking for images with a single keyword over one catalog cannot find all (or even most of) the images.  For anyone using smart albums, you might check to see whether you're getting everything you should be.
Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #1 on: August 29, 2013, 10:27:40 PM »

No one seeing this but me?
Logged

David Grover / Phase One

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1170
    • Phase One
Re: problems with smart folders/keywords
« Reply #2 on: September 02, 2013, 11:03:13 AM »

What version of Capture One are you running?
Logged
David Grover
Business Support and Development Manager, Software.

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #3 on: September 04, 2013, 09:09:58 PM »

(Sorry for the delay - dealing with sick pets)

I'm using 7.1.3.  I started with 7.0 and updated through every upgrade version.  I just re-checked my images and settings to be double-sure, and per what I see there should be no problem.  Each of about 90 images (out of ~3000) has one keyword, and my smart album is set to include all images that contain that keyword.  And yet the smart album only includes a handful of images.  One catalog, all images managed.

One thing PhaseOne support had me do was verify the catalog to look for errors and fix if found.  I'm finding that if I run verify I'm as likely to get errors as not.  I tried it again just now and it needed repair.  After repair, the behavior was unchanged.  When support heard about this earlier, they suggested making a new catalog and re-populating it with the same images.  I've done that, and it changed nothing. 

I really like the image quality and tools in C1 pro, but their database management leaves a lot to be desired IMO.
Logged

nik

  • Full Member
  • ***
  • Offline Offline
  • Posts: 213
    • Nick Vasilopoulos Photography
Re: problems with smart folders/keywords
« Reply #4 on: September 06, 2013, 03:01:19 PM »

I've seen incomplete results like you're describing if you have a Filter (via the FILTERS tool, eg Rating / Color Tag / Date) applied and then try to smart filter on that already applied filter. Make sure your filters are set to none before Smart Filtering.

-N
Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #5 on: September 06, 2013, 05:01:19 PM »

I've double-checked again.  There are no filters set.  CO sees only 7 total images with the one keyword.  Yet there are many, many more.  The filter panel shows 4 taken on one date, and 3 taken on another.  ALL of the other filter criteria report either 0 or these same 7 images.  The keyword is not misspelled or suffering from typos.  Approx. 90 images have this same keyword.  CO only sees 7 of them.  It's crazy...
Logged

nik

  • Full Member
  • ***
  • Offline Offline
  • Posts: 213
    • Nick Vasilopoulos Photography
Re: problems with smart folders/keywords
« Reply #6 on: September 06, 2013, 11:49:50 PM »

If you create another smart filter (different name) with the same filter criteria do you get the same 7 results? or different results ?  Again, I agree, smart filters are a bit flaky. I've seen smart filters show NO results but when I rename / edit or create a new filter with the same criteria I get results. Frustrating.
Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #7 on: September 07, 2013, 09:10:03 AM »

Thanks for the suggestion.  I tried it and the new smart folder finds the same 7 images.  I even took one of the images these smart folders aren't finding, deleted the keyword, and then re-added the keyword.  No good.  Still the same 7 images.  Very frustrating and renders smart folders useless for me.
Logged

nik

  • Full Member
  • ***
  • Offline Offline
  • Posts: 213
    • Nick Vasilopoulos Photography
Re: problems with smart folders/keywords
« Reply #8 on: September 07, 2013, 01:07:50 PM »

This is a long shot and feel free to ignore it if you think it's a timewaster but have you considered the underlying filesystem? I assume you are on Mac OSX. Have you done an integrity check on your drive's Permissions (Verify Permissions) and Physical disk (Verify Disk) with Disk Utility or a tool like Techtool? If problems exist at this level (especially disk verification errors) they will cause problems for you further up the application chain. See attached for Disk Verification.

Best,

Nik

Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #9 on: September 07, 2013, 04:46:26 PM »

I verified both the startup disk and the data disk and both came back as "appear to be OK".  Checked permissions on the startup disk, and all is OK except My Epson 3880 and/or scanner, but those permissions are ALWAYS showing as incorrect and virtually never get fixed.  (But both work as they should.)
Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #10 on: September 17, 2013, 09:27:52 PM »

Just downloaded and installed 7.1.4 to see if it would help.  The program is quicker/more responsive, but the smart folders still don't work. 
Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #11 on: November 20, 2013, 07:23:31 PM »

FIXED WITH 7.1.5 !
Logged

David Grover / Phase One

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1170
    • Phase One
Re: problems with smart folders/keywords
« Reply #12 on: November 21, 2013, 04:07:37 AM »

Logged
David Grover
Business Support and Development Manager, Software.

lo.troeller

  • Newbie
  • *
  • Offline Offline
  • Posts: 1
Re: problems with smart folders/keywords
« Reply #13 on: November 23, 2013, 05:54:42 AM »

Glad to hear that. I have the exact problem on a windows pc, running windows 7 and CO PRO 7.1.5 - I guess I have to wait for 7.1.6...
Compared to Lightroom it's a pain, but me too I like the image quality.
Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #14 on: December 04, 2013, 10:28:35 PM »

I spoke too soon it seems - smart folders are totally flaky again.  The gist still is that creating a smart folder only finds a subset of the images it should find.  To make matters worse, since I could not rely on a smart folder based on keywords, I gave each one of 477 images a color tag (purple) and then *in the same dialog box* where I was asked if I would like these images to be made into a smart folder (a folder now based only on the color tag) I said "yes".  The new smart folder based solely on being tagged purple now showed only 136 of the 477 images!  ANY way I create a smart folder, it always finds only a subset of the images.  Smart folders are not smart, they're useless.
Logged

allegretto

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 660
Re: problems with smart folders/keywords
« Reply #15 on: December 04, 2013, 11:35:33 PM »

what you need to be careful of is that only an album can hold images and there one can many different albums per session or catalog

so it is not at all difficult for your search to be more narrow than you thought, with some albums, and thus images "ignored" in the query. C1 is so darn open in how you set it up, you can fool yourself. Ask me how I know...

So the most "global" a search can go is to the top of the open catalog that you initiated the search in (hope that makes sense). So purple flagged images in THAT catalog is all you will get unless

1) you only have one master catalog and do your searches in that catalog

or

2) Use Media Pro, which allows queries across multiple catalogs as long as you have organized it properly

Once you get a feel for the db you are limited to it makes perfect sense.
Logged

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #16 on: December 04, 2013, 11:43:34 PM »

All my images are in ONE catalog.  I highlighted "all images" when I queried and found the ~477 images and let CO build a smart folder from what it just found (It actually offers to build a smart folder for you based on the results you just got).  Then that smart folder had only a quarter of those images.  I don't think it's me, I think it's broken.
Logged

allegretto

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 660
Re: problems with smart folders/keywords
« Reply #17 on: December 05, 2013, 09:23:53 AM »

ummmm, have not seen anything like that and done a lot of queries and back-checks

it is possible that your metadata isn't quite what you think it is. For example, there may be a filter on that causes it to not include some images

it's just a query and that's hard to believe that it's "broken". One would think that such an otherwise rich and robust program would not be "broken" on just your computer... no?
Logged

Doug Peterson

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 3321
    • http://www.doug-peterson.com
Re: problems with smart folders/keywords
« Reply #18 on: December 05, 2013, 10:00:51 AM »

For what it's worth my personal catalog and office catalog are both working without issue. I have about a dozen smart albums on the office catalog which allow us to quickly query images shot with specific backs, generations of backs, or specific lenses.

C1 v7.1.5 on Mac Pro with OSX 10.8.5 and MacBookPro with OSX 10.9.
Logged
DOUG PETERSON (dep@digitaltransitions.com), Digital Transitions
Dealer for Phase One, Mamiya Leaf, Arca-Swiss, Cambo, Profoto
Office: 877.367.8537
Cell: 740.707.2183
Phase One IQ250 FAQ

dandaman56

  • Newbie
  • *
  • Offline Offline
  • Posts: 22
Re: problems with smart folders/keywords
« Reply #19 on: December 05, 2013, 03:29:33 PM »

Perhaps not broken for everyone - certainly broken for me.  And a support ticket did not solve the problem. 
 
Logged
Pages: [1]   Go Up