Pages: [1]   Go Down

Author Topic: Copy Aperture library but fail  (Read 14245 times)

Paul Chan

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Copy Aperture library but fail
« on: July 25, 2013, 12:50:02 PM »

I tried to copy the Aperture Library but got the following error. Though errors exist, I can view all the pics by Aperture without any problems. Is there any way I can "SAVE AS" my aperture library to a different location?


The Finder can’t complete the operation because some data in “Aperture Library” can’t be read or written.
(Error code -36)
Logged

francois

  • Sr. Member
  • ****
  • Online Online
  • Posts: 8008
Re: Copy Aperture library but fail
« Reply #1 on: July 26, 2013, 08:55:54 AM »

Did you try to copy your library on your hard drive (i.e. a duplicate) or to an external drive to  to a networked volume?

For local volumes, a -36 error doesn't sound good at all…  :'(
Logged
Francois

Paul Chan

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: Copy Aperture library but fail
« Reply #2 on: July 26, 2013, 01:09:40 PM »

I tried to copy to the same hard drive in a different folder but failed. I tried a few different actions:

1. rebuild aperture library
2. disk utility to check integrity

All of these shows no errors at all.

My timemachine is working fine, therefore I recover the library to a different folder but some of the photos have errors.

How can we save the opened library under Aperture in a different name of different folder, just like MS Word saved the file in a different name?
Logged

jwstl

  • Full Member
  • ***
  • Offline Offline
  • Posts: 122
Re: Copy Aperture library but fail
« Reply #3 on: July 26, 2013, 03:25:01 PM »

I'm no Aperture expert but I wonder if this would work:

In the original library create a new Project that contains all images
Export that Project as a Library (select Project and right click/Export Project as Library or File/Export/Project as Library
Logged

sharperstill

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 72
Re: Copy Aperture library but fail
« Reply #4 on: July 27, 2013, 06:32:31 PM »

I suspect when you say you can see the photos that you are looking at the previews only. I suspect also you have some corrupt data in the original raw files.
This happened to me 3 times in as many years as in the reason I no longer go near Aperture.
You didn't mention if you are working with managed or referenced originals. This would have a bearing on any further advice I gave...

Jon
Logged

KirbyKrieger

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 419
    • Kirby Krieger Pictures
Re: Copy Aperture library but fail
« Reply #5 on: July 28, 2013, 09:03:15 AM »

I tried to copy to the same hard drive in a different folder but failed. I tried a few different actions:

1. rebuild aperture library
2. disk utility to check integrity

All of these shows no errors at all.

My timemachine is working fine, therefore I recover the library to a different folder but some of the photos have errors.

How can we save the opened library under Aperture in a different name of different folder, just like MS Word saved the file in a different name?

Hi Paul,

The Aperture Library is a database wrapped in a Finder package file.  Although it appears to the user as a single document file (like a Word doc), it is quite different.  You can't "save as" and thus create a duplicate.  You must duplicate the Library file using a file manager (e.g.: Finder), at which point it will be automatically given a unique name (which you can change, again using a file manager).

Have you repaired Aperture permissions (directions are on Apple's Aperture trouble-shooting page), as well as your system permissions (via Disk Utility)?  If not, I would do so.

The indications are (as mentioned in this thread) that you have a corrupt file (or files) in your Library.  Afaik, there is nothing to do except search them out manually.  Check the Apple Aperture Discussion forum for suggestions on how to do this (look for posts by LeonieDF).

sharperstill

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 72
Re: Copy Aperture library but fail
« Reply #6 on: July 28, 2013, 09:19:50 AM »

If your library is 'managed' and all your raw files are bundled up inside that Library file ( as discussed above) there is an Automator action that will extract all your raw files from that library.

The extracted raw files will have no adjustments or metadata, they'll be as they were off the camera, and some will be likely corrupt, but at least you'll have them as a copy while you try other strategies.

First thing I'd do is run DiskWarrior on your drive.

Jon
Logged

Paul Chan

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
Re: Copy Aperture library but fail
« Reply #7 on: July 29, 2013, 05:27:23 AM »

Thanks all for advise.

I did run the disk utility but nothing to repair in permission.  I haven't opened each photo because it is not possible to open 10K photo one by one. May be I need to restore some of my Time Machine archive and see when the problem started.

BTW I have mentioned, the copy process looked good until 4.6G and then it stopped and reported error.
Logged

francois

  • Sr. Member
  • ****
  • Online Online
  • Posts: 8008
Re: Copy Aperture library but fail
« Reply #8 on: July 29, 2013, 06:24:23 AM »

Paul,
Glad to see that you have a backup copy of your Aperture library. That being said, I would be worried if my hard drive had -36 Finder errors. If you encounter more -36 errors, then you should really plan to replace your hard rive. And remember to backup, backup, backup!
Logged
Francois
Pages: [1]   Go Up