Pages: [1]   Go Down

Author Topic: Unsupported image files that Aperture processed  (Read 7344 times)

Chairman Bill

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2344
    • flickr page
Unsupported image files that Aperture processed
« on: December 28, 2012, 03:16:43 PM »

I'm transferring files from my old Aperture library on my old iMac, to a new library on my new iMac. Same version of Aperture. Should be no problems. Except, Aperture on my new iMac is a bit choosy about which files it will read.

I've imported images in batches, establishing a nice new library structure as I go. The export of images from the old Mac to a usb drive goes without any problems, but when I then import into my new Mac, every now & then a photo gets tagged as being an 'unsupported image format'. Quite how it can be unsupported by Aperture, when Aperture processed the damned thing in the first place, is beyond me.

Any solutions/suggestions?

msbc

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 95
Re: Unsupported image files that Aperture processed
« Reply #1 on: December 28, 2012, 09:05:58 PM »

RAW file support is provided by Digital Camera RAW which is an operating system framework, not Aperture directly. Do you have different version of DCR on the two iMac's? Check with Aperture>About Aperture - latest version is 4.03

Mark
Logged
Mark Connell
Melbourne, Australia

francois

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 8116
Re: Unsupported image files that Aperture processed
« Reply #3 on: December 29, 2012, 04:53:32 AM »

'Tis all the same stuff. And it's one or two in a batch of photos. All from the same camera, with others perfectly fine. Very odd.

Any messages in the Console (other than the useless "Unsupported File Format")?

Edit: Can Preview.app open these problematic files?
« Last Edit: December 29, 2012, 04:57:46 AM by francois »
Logged
Francois

francois

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 8116
Re: Unsupported image files that Aperture processed
« Reply #5 on: December 29, 2012, 11:25:39 AM »

Seems sorted now - when I go to the adjustments pane, the image appears. Prior to that, exif data suggested there was nothing there (though it had the camera/lens combo correct), but now it reads normally.

Missing images now reinstated. Weird behaviour though.

Glad to see that your issue is fixed but Aperture's behaviour is a bit unsettling!
Logged
Francois

jonathanlung

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 70
Re: Unsupported image files that Aperture processed
« Reply #6 on: January 05, 2013, 01:52:52 PM »

Maybe it's time for a library rebuild/repair.
Logged

Graham Clark

  • Full Member
  • ***
  • Offline Offline
  • Posts: 179
    • grahamclarkphoto.com
Re: Unsupported image files that Aperture processed
« Reply #7 on: February 25, 2013, 03:51:20 PM »

When transferring from one machine to another transfer only projects or libraries, not individual images.

1. Old machine - drag library to external disk
2. New Machine - drag library to internal disk
3. double-click
4. done
Logged
Graham Clark  |  grahamclarkphoto.com
Pages: [1]   Go Up