Pages: [1] 2   Go Down

Author Topic: LR4 crashing  (Read 5521 times)

jljonathan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 144
LR4 crashing
« on: January 14, 2012, 02:46:26 PM »

Anyone else have this behavior? Made a new catalog and imported as copies dng files that were from LR3. Ok in library and map, but getting repeat crashes when I move to develop module. Won't allow to use develop.
Jonathan
Logged

Rhossydd

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2370
    • http://www.paulholman.com
Re: LR4 crashing
« Reply #1 on: January 14, 2012, 03:05:35 PM »

I've had a few crashes moving between modules, a couple in map and a complete BSOD in develop.
W7 64bt

So far this has been the worst behaving version of Lightroom ever released.
Every other version from the very first version 1 beta has been rock solid, rather disappointing so far :(
Logged

John R Smith

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1357
  • Still crazy, after all these years
Re: LR4 crashing
« Reply #2 on: January 14, 2012, 03:30:19 PM »

So far this has been the worst behaving version of Lightroom ever released.
Every other version from the very first version 1 beta has been rock solid, rather disappointing so far :(

Not so, at least in my experience. LR 3.0 was horrendous (not the beta, the first full release). Adobe quickly rushed out 3.2 to fix the most obvious bugs (no-one will ever know what happened to 3.1). And then there was 3.4, which had some horrible snags which were very quickly patched up by 3.4.1 and 3.4 was history. To be fair, the bugs do get fixed given time. And LR4 is a beta, so there will be little problems of course.

John
Logged
Hasselblad 500 C/M, SWC and CFV-39 DB
and a case full of (very old) lenses and other bits

meyerweb

  • Full Member
  • ***
  • Offline Offline
  • Posts: 163
Re: LR4 crashing
« Reply #3 on: January 14, 2012, 05:21:46 PM »

I've had a few crashes moving between modules, a couple in map and a complete BSOD in develop.
W7 64bt

So far this has been the worst behaving version of Lightroom ever released.
Every other version from the very first version 1 beta has been rock solid, rather disappointing so far :(

Hardly fair to use the word "released."  It's a beta, not a release version. Bugs are to be expected in an early beta. If you don't want to put up with them, keep using the release version (3.6).
Logged

jljonathan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 144
Re: LR4 crashing
« Reply #4 on: January 14, 2012, 05:50:34 PM »

"Little problems" is not how I would characterize this behavior. Consistent immediate crashes when moving to the develop module. Things are ok in the library and map modules. I'm on MAC 10.6.8 Anyone have this problem, or any suggestions?
Jonathan
Logged

Rhossydd

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2370
    • http://www.paulholman.com
Re: LR4 crashing
« Reply #5 on: January 14, 2012, 06:07:33 PM »

Hardly fair to use the word "released."  It's a beta, not a release version. Bugs are to be expected in an early beta. If you don't want to put up with them, keep using the release version (3.6).
In the context of beta software; Released = available to the public to try

No, I don't, and never have expected, beta software to be perfect, and yes, I only trust the full versions for any 'proper' work.
However my past experience with Lightroom in beta has been that it was exceptionally good, this is the first beta ever that's been problematic.
« Last Edit: January 14, 2012, 06:28:33 PM by Rhossydd »
Logged

jljonathan

  • Full Member
  • ***
  • Offline Offline
  • Posts: 144
Re: LR4 not crashing now.
« Reply #6 on: January 14, 2012, 09:35:05 PM »

I tried a solution from a similar thread in the Adobe LR 4 forum. Process version 2010 does not get along with 2012. I hit the update and now it seems not to crash in develop.
Logged

wolfnowl

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 5821
    • M&M's Musings
Re: LR4 crashing
« Reply #7 on: January 15, 2012, 01:23:43 AM »

This won't help the OP, but using LR4 Beta in Win 7/ 32-bit I've had no problems with 2010 or 2012 process versions.  Just one man's experience.

Mike.
Logged
If your mind is attuned to beauty, you find beauty in everything.
~ Jean Cooke ~

My Flickr site / Random Thoughts and Other Meanderings at M&M's Musings

ErikKaffehr

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 9960
    • Echophoto
Re: LR4 crashing
« Reply #8 on: January 15, 2012, 02:04:30 AM »

Hi,

The Beta seem very crashprone to me, but the features hold a great promise.

My guess is that our systems are different enough, so stuff that works fine on one system may work awful on another. But I presume that Adobe irins out the wrinkles and when LR4 is released it will fly.

Best regards
Erik


This won't help the OP, but using LR4 Beta in Win 7/ 32-bit I've had no problems with 2010 or 2012 process versions.  Just one man's experience.

Mike.

mac_paolo

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 429
Re: LR4 crashing
« Reply #9 on: January 15, 2012, 02:12:28 AM »

I think these threads should be really opened and discussed on Adobe forums.
Lr4 beta is fine to have a taste of new functions, new direction, new possibilities... but it's still the very first public beta.
Crashes are common: can't be used in productions environments.
Logged

Rhossydd

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2370
    • http://www.paulholman.com
Re: LR4 crashing
« Reply #10 on: January 15, 2012, 05:44:18 AM »

Crashes are common:
In past LR betas they haven't been.
Adobe did a really good job releasing good stable code in their previous betas.
Logged

mac_paolo

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 429
Re: LR4 crashing
« Reply #11 on: January 15, 2012, 08:16:21 AM »

In past LR betas they haven't been.
Adobe did a really good job releasing good stable code in their previous betas.
For what is worth, I disagree. I'm involved in beta testing since Lr2, and for both 2.0 and 3.0 I encountered a LOT of crashes before (and sometimes after) the GM.
Logged

John R Smith

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1357
  • Still crazy, after all these years
Re: LR4 crashing
« Reply #12 on: January 15, 2012, 11:43:00 AM »

It is very educational to visit the Adobe Lightroom Downloads page (and it may jog a few memories, just to set the record straight) -

http://www.adobe.com/support/downloads/product.jsp?product=113&platform=Windows

Noticeable by their absence are LR 1.0, LR 2.0, and LR 3.0. I had LR 3.0 (and I still have it on CD in a boxed copy). It was horrendous, and we all upgraded to 3.2 as fast as we could download it. I assume that 1.0 and 2.0 were just as buggy, which is why they are no longer available.

So I certainly would not be rushing to upgrade to LR 4.0 when it does come out if I were you, but would prudently wait for 4.1  ;)

John
Logged
Hasselblad 500 C/M, SWC and CFV-39 DB
and a case full of (very old) lenses and other bits

Akro

  • Newbie
  • *
  • Offline Offline
  • Posts: 5
    • Randolph Henson Photography
Re: LR4 crashing
« Reply #13 on: January 18, 2012, 12:09:15 AM »

Mine crashes every time I try to enter the Develop Module when I have selected a  photo that was previously edited in LR3.6

Anthony.Ralph

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 60
Re: LR4 crashing
« Reply #14 on: January 18, 2012, 08:04:39 AM »

Mine crashes every time I try to enter the Develop Module when I have selected a  photo that was previously edited in LR3.6

I have been having similar problems over the last couple of days, so you are not alone.

Anthony.
Logged

David Eichler

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 547
    • San Francisco Architectural and Interior Photographer
Re: LR4 crashing
« Reply #15 on: January 20, 2012, 04:10:38 PM »

Not so, at least in my experience. LR 3.0 was horrendous (not the beta, the first full release). Adobe quickly rushed out 3.2 to fix the most obvious bugs (no-one will ever know what happened to 3.1). And then there was 3.4, which had some horrible snags which were very quickly patched up by 3.4.1 and 3.4 was history. To be fair, the bugs do get fixed given time. And LR4 is a beta, so there will be little problems of course.

John

It took them until LR 3.5 to fix memory usage problems that were causing severe unresponsiveness with the clone and brush tools with my system (2.5 year old 24" iMac with Snow Leopard and 8 gigs of RAM). I think I will have to wait until they are getting close to releasing LR 5 before upgrading to LR4. :-(
Logged

John R Smith

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1357
  • Still crazy, after all these years
Re: LR4 crashing
« Reply #16 on: January 21, 2012, 05:07:50 AM »

David, I would agree. LR 3.5 has settled down very nicely on my Win 7 64-bit machine, and at last it seems stable and quick. So I, for one, am certainly in no hurry to upgrade to anything.

However, we can deal with all of this on a no-risk basis (at least initially). When LR 4.0 final comes out, there will be a thirty-day trial. So we can see how the thing beds down before we lay out any cash. I wish I had done that with 3.0.

John
Logged
Hasselblad 500 C/M, SWC and CFV-39 DB
and a case full of (very old) lenses and other bits

patrickt

  • Newbie
  • *
  • Offline Offline
  • Posts: 14
Re: LR4 crashing
« Reply #17 on: January 21, 2012, 09:33:59 AM »

Problems are to be expected from betas.

My desktop computer has performed perfectly. For fun, I went back to my first raw files, 2005, and imported them to edit. I enjoyed using LR4 beta and had no problems.

On my Lenovo laptop, I had it shut down twice in the develop module. In both cases I restarted LR4 bata and it returned to a point a couple of steps before the shutdown. Interesting.

I use Windows7 64bit on both the desktop and the laptop. I am working with Pentax raw files, .pef.
Logged

reburns

  • Full Member
  • ***
  • Offline Offline
  • Posts: 142
    • Ralph E Burns Photography
Re: LR4 crashing
« Reply #18 on: December 07, 2012, 02:17:23 PM »

My Lightroom has been crashing for awhile now.  I'm on LR4 and fully updated.  It crashes upon program launch at least 50% of the time.  Then when I relaunch is almost always starts successfully.  So my work-around is just to hammer it, but I do worry about corrupt libraries and other gremlins.  Windows 7, Dell M6500.

Any thoughts / suggestions?
Logged

kaelaria

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2223
    • http://www.bgpictures.com
Re: LR4 crashing
« Reply #19 on: December 07, 2012, 07:52:34 PM »

I too have random crashes when launching.  It started on this latest version only.
Pages: [1] 2   Go Up