Pages: [1] 2 3   Go Down

Author Topic: Epson 9900 photo print bad...help!  (Read 8691 times)

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Epson 9900 photo print bad...help!
« on: January 26, 2011, 01:05:32 PM »

I am hoping I can get some help with a problem I am having with my Epson 9900. I have had this machine since October of 2009 and I have always used Epson brand ink and paper. In the past I have been able to print beautiful photographs without a single problem. As of this month they have been printing like this...
Original Image

Bad Image


I hope you can see the difference between the two. I have seen a similar "look" when an inkjet printed on paper specific for a laser printer, but this machine has never done this before and I have tried everything i can think of, im going nuts!

I can print the same thing on matte paper and it look okay. I have tried several different rolls of photo paper and they all look the same.
I told the print driver that it was matte paper, left the glossy in and switched to matte black and it looked okay. Although you can tell it is matte black on glossy. I have also tried changing to a different profile, still the same output.

I have cleaned and done nozzle checks several times, I cant tell anything is wrong from that, it looks fine.

I hope all of this makes sense to someone. I will take any help/suggestions I can get.

thanks
b
Logged

Schewe

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 5982
    • http:www.schewephoto.com
Re: Epson 9900 photo print bad...help!
« Reply #1 on: January 26, 2011, 01:11:43 PM »

Just a quick question...are you 100% sure that the paper is loaded correctly with the coated surface being printed on? what paper are you using?
Logged

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #2 on: January 26, 2011, 02:15:01 PM »

Yes it is the coated side, because the back side says Epson all over it :) I am using the Epson Premium Photo Glossy 170.
Logged

langier

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 812
    • Celebrating Rural America and beyond
Re: Epson 9900 photo print bad...help!
« Reply #3 on: January 26, 2011, 04:32:25 PM »

Similar problem several years ago...caused by a glitch in an update to Photoshop CS 3 that was corrected in a couple of weeks. You are using a newer version of PS?
Logged
Larry Angier
ASMP, NAPP, ACT, and many more!

Webmaster, RANGE magazine
Editor emeritus, NorCal Quarterly

web--http://www.angier-fox.photoshelter.com
facebook--larry.angier
twitter--#larryangier
google+LarryAngier

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #4 on: January 26, 2011, 04:34:15 PM »

I am using CS5 but have been for quite a while so not sure if that would be the problem or not. I also tried printing from powerpoint with the same photos and it did the same thing.

thanks for the responses so far, i just know the answer is out there :)
« Last Edit: January 26, 2011, 05:55:51 PM by bhuddleston »
Logged

Farmer

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1684
    • http://
Re: Epson 9900 photo print bad...help!
« Reply #5 on: January 26, 2011, 05:24:12 PM »

Two things:

1. Do a nozzle check.  How does it look?

2. Are you sure you have set to PhotoBlack?
Logged

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #6 on: January 26, 2011, 05:55:23 PM »

1. yes, done several of those, looks great as far as i can tell, no skips or anything.

2. yes

:(
« Last Edit: January 26, 2011, 06:02:55 PM by bhuddleston »
Logged

na goodman

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 387
Re: Epson 9900 photo print bad...help!
« Reply #7 on: January 26, 2011, 06:25:08 PM »

When you soft proof in CS5 is the bad print what you see? Try copying the file to a new CS5 file and printing.
Logged

Farmer

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1684
    • http://
Re: Epson 9900 photo print bad...help!
« Reply #8 on: January 26, 2011, 07:08:52 PM »

Can you confirm *EVERY* setting and step when printing from CS5, please?  Both in CS5 and the driver?  Screen shots would be great.
Logged

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #9 on: January 27, 2011, 09:33:11 AM »

When you soft proof in CS5 is the bad print what you see? Try copying the file to a new CS5 file and printing.

the bad print above is a scan of what actually printed
Logged

na goodman

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 387
Re: Epson 9900 photo print bad...help!
« Reply #10 on: January 27, 2011, 09:40:56 AM »

So, it does not look like that when you soft proof in Photoshop? I think I would try another luster or gloss paper, just to make sure it isn't the inkjet coating on the paper. It almost looks like when a print solarizes.
Logged

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #11 on: January 27, 2011, 12:03:27 PM »

So, it does not look like that when you soft proof in Photoshop? I think I would try another luster or gloss paper, just to make sure it isn't the inkjet coating on the paper. It almost looks like when a print solarizes.

No it always looks great on like a laser printer and just in photoshop itself. I have tried two other photo papers and get the same thing.
Logged

Doombrain

  • Full Member
  • ***
  • Offline Offline
  • Posts: 213
Re: Epson 9900 photo print bad...help!
« Reply #12 on: January 27, 2011, 12:16:23 PM »

can you try another computer, looks like a driver issue
Logged

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #13 on: January 28, 2011, 01:05:45 PM »

can you try another computer, looks like a driver issue

Did that and didnt make a difference :( still terrible print.
Logged

Farmer

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1684
    • http://
Re: Epson 9900 photo print bad...help!
« Reply #14 on: January 28, 2011, 03:28:26 PM »

Really still need to know your complete workflow through PS and the driver in order to see if something is going wrong.
Logged

KevinWilliams

  • Newbie
  • *
  • Offline Offline
  • Posts: 48
Re: Epson 9900 photo print bad...help!
« Reply #15 on: January 28, 2011, 03:57:19 PM »

Have you ran any maintenance tests? it looks like one of the channels is not firing and is lacking a color.
Logged

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #16 on: January 28, 2011, 03:57:53 PM »

Okay, here goes, sorry for the big screen shots but i think they are too hard to see if they aren't big :) so I am using PS CS5.

Open my photo, go to print, select my epson 9900, go to settings

Choose Premium Photo Glossy 170 - which is the roll I have installed.


I chose the quality, although I have checked them all and knocked it up to a 4 (didnt make a difference)


I do not change the paper configuration since this is the default for this type of paper, or is suppose to be anyway.


Of course i tell it what size roll and what size document (didn't think pictures were needed for this)

then this is back to my print box in photoshop
Logged

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #17 on: January 28, 2011, 03:59:27 PM »

Kevin that is exactly what I am thinking. I have done several nozzle checks, regular cleanings, a power cleaning. Now if there is some secret maintenance thing I am all ears lol.

thanks
Logged

FranciscoDisilvestro

  • Sr. Member
  • ****
  • Online Online
  • Posts: 944
    • Frank Disilvestro
Re: Epson 9900 photo print bad...help!
« Reply #18 on: January 28, 2011, 04:38:54 PM »

Hello,

In the Epson driver you choose Premium Photo Glossy 170 but then in the Photoshop dialog you have selected "Epson Stylus Pro Archivalmatte paper" in the printer profile. This does not look right

bhuddleston

  • Newbie
  • *
  • Offline Offline
  • Posts: 46
Re: Epson 9900 photo print bad...help!
« Reply #19 on: January 28, 2011, 04:54:49 PM »

yea sorry that was just in this screen shot, I have had it set on the photo 170 and have also tried several others with no luck.
Logged
Pages: [1] 2 3   Go Up