Pages: [1]   Go Down

Author Topic: LR3 Publishing Service too slow !  (Read 2709 times)

malam

  • Newbie
  • *
  • Offline Offline
  • Posts: 28
LR3 Publishing Service too slow !
« on: October 30, 2010, 03:13:57 PM »

It appears that LR3 Publishing service is running too slow.  Infact, its not running, its crawlling.  Somehow, its not using the full capacity of my available memory or cpu power.  I have an intel i7 950  3.07 G cpu and 12m of memmory.  Everest shows that the CPU is running at 1.6 G which means that LR3 is not demanding for more power.  What I'm I doing wrong?? Is there a setting in LR3 that I am missing or have wrong?  I am trying to publish to Smugmug.
Thanks for your help.
Logged

feppe

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2903
  • Oh this shows up in here!
    • Harri Jahkola Photography
Re: LR3 Publishing Service too slow !
« Reply #1 on: October 31, 2010, 08:40:27 AM »

It appears that LR3 Publishing service is running too slow.  Infact, its not running, its crawlling.  Somehow, its not using the full capacity of my available memory or cpu power.  I have an intel i7 950  3.07 G cpu and 12m of memmory.  Everest shows that the CPU is running at 1.6 G which means that LR3 is not demanding for more power.  What I'm I doing wrong?? Is there a setting in LR3 that I am missing or have wrong?  I am trying to publish to Smugmug.
Thanks for your help.

I don't know the inner workings of the service, but it appears it processes each picture at a time. So perhaps your internet connection is not fast enough, so LR idles most of the time, waiting for a picture to be uploaded before processing the next one?

Also, Adobe's products aren't the best at utilizing multiple cores.

stevebri

  • Full Member
  • ***
  • Offline Offline
  • Posts: 190
Re: LR3 Publishing Service too slow !
« Reply #2 on: October 31, 2010, 02:36:14 PM »

Lightroom utilizes all four cores in the PC world, give it loads of RAW's to convert and then take a look at performance under the task manager, all 4 get hit almost equally.

Also Lightroom can do more than one job at once, so you can leav it rendering previews whilst you quickly process 20 shots for a website, it will run them plus two more jobs at the same time and really hammer your CPU's cores, your cached physical memory and the speed of your hard drive link.

S
Logged

PeterAit

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2546
    • Peter Aitken Photographs
Re: LR3 Publishing Service too slow !
« Reply #3 on: November 07, 2010, 02:30:51 PM »

It's the upload speed, I bet. I have similar problems when publishing a web album, it takes way longer than should be required just for the image processing.
Logged
Peter
"Photographic technique is a means to an end, never the end itself."
View my web page
View my Facebook page

dtsiapas

  • Newbie
  • *
  • Offline Offline
  • Posts: 26
    • http://www.tsiapas.com
Re: LR3 Publishing Service too slow !
« Reply #4 on: April 30, 2011, 02:23:36 PM »

I am also experiencing very slow performance of Publish Services and it has nothing to do with either network speed or pc performance. I work with my lightroom catalog on two pcs, one at the studio (asus p5kc, intel q9550 @3.75Ghz) and one at home (asus p8p67, intel 2600k @4.7Ghz). At the studio lightroom responds very fast when working with publish services, but at home when working with the same catalog Lightroom publish services are extremely sluggish. Note that the adsl actual speed is even faster at home. I have experimented with new catalogs but the problem at home is persistent.

/Dimitris

feppe

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 2903
  • Oh this shows up in here!
    • Harri Jahkola Photography
Re: LR3 Publishing Service too slow !
« Reply #5 on: May 01, 2011, 02:38:59 PM »

I am also experiencing very slow performance of Publish Services and it has nothing to do with either network speed or pc performance. I work with my lightroom catalog on two pcs, one at the studio (asus p5kc, intel q9550 @3.75Ghz) and one at home (asus p8p67, intel 2600k @4.7Ghz). At the studio lightroom responds very fast when working with publish services, but at home when working with the same catalog Lightroom publish services are extremely sluggish. Note that the adsl actual speed is even faster at home. I have experimented with new catalogs but the problem at home is persistent.

Have you done a network speed test on the connections? ADSL is asymmetrical by definition, so your upload speed is a fraction of your download speed.

dtsiapas

  • Newbie
  • *
  • Offline Offline
  • Posts: 26
    • http://www.tsiapas.com
Re: LR3 Publishing Service too slow !
« Reply #6 on: May 01, 2011, 03:02:20 PM »

My problem is not about network speed. Lightroom seems to be very sluggish when I just expand the Publish services panel. When this panel is collapsed or hiden Lightroom is as fast as it it supposed to be. The problems occur when I just access the Publish services panel.
Pages: [1]   Go Up