Pages: [1] 2   Go Down

Author Topic: Yeah, my new web site - budjamesphotography.com  (Read 10499 times)

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« on: April 20, 2008, 07:33:36 AM »

I just put up my new and first web site on my personal domain:

http://www.budjamesphotography.com

Please check it out when you have a chance and post your comments.

Thanks.

Bud James
« Last Edit: April 20, 2008, 05:48:25 PM by budjames »
Logged
Bud James
North Wales, PA
www.budjamesphotography.com

Justinr

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1506
    • Ink+images
Yeah, my new web site - budjamesphotography.com
« Reply #1 on: April 20, 2008, 01:07:02 PM »

Quote
I just put up my new and first web site on my personal domain: www.budjamesphotography.com.

Please check it out when you have a chance and post your comments.

Thanks.

Bud James
[a href=\"index.php?act=findpost&pid=190747\"][{POST_SNAPBACK}][/a]


I was asked for a password so went no further.

Justin.
Logged

francois

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 7993
Yeah, my new web site - budjamesphotography.com
« Reply #2 on: April 20, 2008, 01:46:04 PM »

Quote
I was asked for a password so went no further.

Justin.
[a href=\"index.php?act=findpost&pid=190792\"][{POST_SNAPBACK}][/a]
No password for me (Safari)! I could see portfolios...

Edit: Nice photos, indeed...
« Last Edit: April 20, 2008, 02:15:02 PM by francois »
Logged
Francois

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« Reply #3 on: April 20, 2008, 01:50:29 PM »

Quote
I was asked for a password so went no further.

Justin.
[a href=\"index.php?act=findpost&pid=190792\"][{POST_SNAPBACK}][/a]

Not sure why you were asked for a password. It's a public web site.

Bud
Logged
Bud James
North Wales, PA
www.budjamesphotography.com

JMCP

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 89
Yeah, my new web site - budjamesphotography.com
« Reply #4 on: April 20, 2008, 04:25:50 PM »

Hi,

the password problem is when you copy and paste your website addess into a browser from your post ie copying the full stop at the end of the .com as you end up with www.budjamesphotography.com.  if you see what I mean.  It is always a good idea to put a space between the domain (.com) and a full stop.

Cheers John



Quote
Not sure why you were asked for a password. It's a public web site.

Bud
[a href=\"index.php?act=findpost&pid=190798\"][{POST_SNAPBACK}][/a]
Logged

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« Reply #5 on: April 20, 2008, 05:47:38 PM »

Quote
Hi,

the password problem is when you copy and paste your website addess into a browser from your post ie copying the full stop at the end of the .com as you end up with www.budjamesphotography.com.  if you see what I mean.  It is always a good idea to put a space between the domain (.com) and a full stop.

Cheers John
[a href=\"index.php?act=findpost&pid=190831\"][{POST_SNAPBACK}][/a]


Good tip John. Thanks. Will do.

Bud
Logged
Bud James
North Wales, PA
www.budjamesphotography.com

The View

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1097
Yeah, my new web site - budjamesphotography.com
« Reply #6 on: May 10, 2008, 04:13:13 PM »

I'm just working on a new site myself.

Your welcome page looks very good.

Did you do it yourself? How did you get that texture?

What software was it done with (iWeb?)
« Last Edit: May 10, 2008, 04:15:20 PM by The View »
Logged
Deserts, Cities, Woods, Faces - View of the World.

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« Reply #7 on: May 10, 2008, 05:22:08 PM »

Quote
I'm just working on a new site myself.

Your welcome page looks very good.

Did you do it yourself? How did you get that texture?

What software was it done with (iWeb?)
[a href=\"index.php?act=findpost&pid=194894\"][{POST_SNAPBACK}][/a]

It was a template in iWeb 08. I've been back to Macs for about 14 months now.

Bud James
Logged
Bud James
North Wales, PA
www.budjamesphotography.com

popnfresh

  • Guest
Yeah, my new web site - budjamesphotography.com
« Reply #8 on: May 22, 2008, 08:03:29 PM »

There's a lot of extremely cool photography happening there. You have a remarkable eye. That shot of the flag and bridge in the fog is haunting.
Logged

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« Reply #9 on: May 22, 2008, 09:04:16 PM »

Quote
There's a lot of extremely cool photography happening there. You have a remarkable eye. That shot of the flag and bridge in the fog is haunting.
[a href=\"index.php?act=findpost&pid=197335\"][{POST_SNAPBACK}][/a]

It was actually a late misty morning that was converted to B&W and then the flag hand painted with the help of Photoshop.

Thanks for your comments.

Bud James
Logged
Bud James
North Wales, PA
www.budjamesphotography.com

Chris_T

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 541
Yeah, my new web site - budjamesphotography.com
« Reply #10 on: May 24, 2008, 07:45:37 AM »

Quote
I just put up my new and first web site on my personal domain:

http://www.budjamesphotography.com

Please check it out when you have a chance and post your comments.

Thanks.

Bud James
[{POST_SNAPBACK}][/a]

The pages took forever to load.

Listing number of images per gallery is a nice touch. But the bottom parts of "xx PHOTOS" are clipped.

Hovering over each gallery image on the Portfolios page does not turn the mouse pointer into a pointing finger (a typical hint for a link). Same with images on an individual gallery page.

For more comments on similar sites, check out this thread:

[a href=\"http://luminous-landscape.com/forum/index.php?showtopic=13890]http://luminous-landscape.com/forum/index....showtopic=13890[/url]
Logged

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« Reply #11 on: May 24, 2008, 08:21:11 AM »

Quote
The pages took forever to load.

Listing number of images per gallery is a nice touch. But the bottom parts of "xx PHOTOS" are clipped.

Hovering over each gallery image on the Portfolios page does not turn the mouse pointer into a pointing finger (a typical hint for a link). Same with images on an individual gallery page.

For more comments on similar sites, check out this thread:

http://luminous-landscape.com/forum/index....showtopic=13890
[a href=\"index.php?act=findpost&pid=197693\"][{POST_SNAPBACK}][/a]


Chris, thanks for your comments.

I was curious if you are accessing the internet using dial up or broadband? Yours was the first complaint of pages slow to load.

Regarding the other comments, I'll check it out to see if I can improve the site. I'm using an Apple iWeb template so I'm not sure how much I can change.

Cheers.
Bud James
Logged
Bud James
North Wales, PA
www.budjamesphotography.com

francois

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 7993
Yeah, my new web site - budjamesphotography.com
« Reply #12 on: May 24, 2008, 12:23:36 PM »

Quote
Chris, thanks for your comments.

I was curious if you are accessing the internet using dial up or broadband? Yours was the first complaint of pages slow to load.

Regarding the other comments, I'll check it out to see if I can improve the site. I'm using an Apple iWeb template so I'm not sure how much I can change.

Cheers.
Bud James
[a href=\"index.php?act=findpost&pid=197700\"][{POST_SNAPBACK}][/a]
Curiously, the Portfolios page loaded OK (but not fast) with Safari but refused to load with FireFox (3.0). In fact, everything was OK (title, background, fotter links, headers) but thumbnails of the galleries weren't displayed and clicking where they should be did nothing. FireFox console showed that some error occured at line 100 of your web page. Clearing the cache didn't help. Blog and Welcome page loaded perfectly.
« Last Edit: May 24, 2008, 12:25:50 PM by francois »
Logged
Francois

francois

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 7993
Yeah, my new web site - budjamesphotography.com
« Reply #13 on: May 25, 2008, 06:58:24 AM »

Update: while FireFox 3.0  has an issue displaying with your website (portfolios page only), version 2.0 works fine, just like Safari.
Logged
Francois

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« Reply #14 on: May 25, 2008, 08:56:22 AM »

Quote
Update: while FireFox 3.0  has an issue displaying with your website (portfolios page only), version 2.0 works fine, just like Safari.
[a href=\"index.php?act=findpost&pid=197842\"][{POST_SNAPBACK}][/a]

Firefox 3.0 is a beta is it not?

Bud
Logged
Bud James
North Wales, PA
www.budjamesphotography.com

englishm

  • Full Member
  • ***
  • Offline Offline
  • Posts: 134
    • http://www.pacificlight.ca
Yeah, my new web site - budjamesphotography.com
« Reply #15 on: May 25, 2008, 09:17:00 AM »

Works fine, loads fast, nice images.

So, when were you in Vancouver?  Passing through to Whistler for skiing?  
Logged

francois

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 7993
Yeah, my new web site - budjamesphotography.com
« Reply #16 on: May 25, 2008, 10:26:29 AM »

Quote
Firefox 3.0 is a beta is it not?

Bud
[a href=\"index.php?act=findpost&pid=197854\"][{POST_SNAPBACK}][/a]
Bud,
Correct, although a RC version (release candidate) is available for download. I wouldn't worry too much about this minor issue.
Logged
Francois

Chris_T

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 541
Yeah, my new web site - budjamesphotography.com
« Reply #17 on: May 25, 2008, 12:16:14 PM »

Quote
Chris, thanks for your comments.

I was curious if you are accessing the internet using dial up or broadband? Yours was the first complaint of pages slow to load.

Regarding the other comments, I'll check it out to see if I can improve the site. I'm using an Apple iWeb template so I'm not sure how much I can change.

Cheers.
Bud James
[{POST_SNAPBACK}][/a]

I'm indeed using dialup, for reasons too complicated to explain here. There are still quite a few of us out there, according to these somewhat dated articles:

[a href=\"http://www.websiteoptimization.com/bw/0704/]http://www.websiteoptimization.com/bw/0704/[/url]

http://www.jdpower.com/corporate/news/rele...aspx?ID=2007210

But even if the dialup users have dropped to 5 or 10%, we are still talking about a large number.

As mentioned in the referred thread, the design of a site should serve its OBJECTIVES. For my own site, I would like it to be easily accessible to as wide an audience as possible. But for others, their sites may be intended for a selected audience (with broadband).

Template based sites are easy to create, but difficult to diagnose or customize. In the referred thread, one poster explained why another poster's Apple based site was so dog slow. Can't remember if it has anything to do with iWeb or not though. Try searching that thread.
Logged

Chris_T

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 541
Yeah, my new web site - budjamesphotography.com
« Reply #18 on: May 25, 2008, 12:25:35 PM »

Quote
Curiously, the Portfolios page loaded OK (but not fast) with Safari but refused to load with FireFox (3.0). In fact, everything was OK (title, background, fotter links, headers) but thumbnails of the galleries weren't displayed and clicking where they should be did nothing. FireFox console showed that some error occured at line 100 of your web page. Clearing the cache didn't help. Blog and Welcome page loaded perfectly.
[a href=\"index.php?act=findpost&pid=197725\"][{POST_SNAPBACK}][/a]

The two books I recommended in the referred thread both emphasize the importance of DESIGNING sites with minimal problems to begin with (like avoiding bells and whistles, in particular those cranked out by templates that you cannot diagnose or fix), and TESTING them BEFORE launching. But that is easier said than done given the number of browsers, revs, plugins, etc. out there. Even professionally designed mega sites seem to ignore that important step. Nor do they solicite inputs from their visitors.
Logged

budjames

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 736
    • http://www.budjamesphotography.com
Yeah, my new web site - budjamesphotography.com
« Reply #19 on: May 26, 2008, 04:51:01 AM »

Quote
Works fine, loads fast, nice images.

So, when were you in Vancouver?  Passing through to Whistler for skiing? 
[a href=\"index.php?act=findpost&pid=197856\"][{POST_SNAPBACK}][/a]

Thanks for your comments.

I've been to Vancouver a number of times over the years. And, yes we did a short stay there on our way to skiing in Whistler-Blackcomb. That was one of our favorite ski trips before we had kids. Now that they are old enough to ski, we when to Colorado this year, we want to go back there.

Bud James
Logged
Bud James
North Wales, PA
www.budjamesphotography.com
Pages: [1] 2   Go Up