Pages: [1]   Go Down

Author Topic: Z3200, known working PSU & formatter, printer doesn't boot.  (Read 173 times)

plasakow

  • Newbie
  • *
  • Offline Offline
  • Posts: 14

My PSU & associated board recently started overheating intermittently, so I replaced it with a new one.

Upon installation, the fan runs and the control panel lights up dimly, but with no text.  The formatter board was fully seated.

I reinstalled the old PSU, but now got the same result as with the new PSU.

I have an completely identical, working Z3200 that I can swap parts with for troubleshooting. I installed the suspect formatter in my other, known-working Z3200 just long enough to see it go into boot sequence.  So, it's not the formatter.  Since swapping the old, intermittent PSU & board and the brand new PSU & board doesn't affect the symptoms, it's not the PSU either.

Where I am now:
  • Z3200 with a known working PSU and formatter.
  • On power-up, fan comes on, control panel has only a dim backlight with no text, and the power button isn't lit.
  • Swapped known-working PSUs twice, same symptoms
  • I'm 100% sure I'm installing it correctly and all cables are well seated
« Last Edit: May 12, 2018, 05:44:28 PM by plasakow »
Logged

Mark Lindquist

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1291
  • itís not about the photos we take - itís the ones we leave
    • LINDQUIST STUDIOS
Re: Z3200, known working PSU & formatter, printer doesn't boot.
« Reply #1 on: May 12, 2018, 07:00:11 PM »

Another trouble shooting step you could try, but I doubt it's the issue, would be to take out the control Panel in the known good working machine and try it in the one that's down.

You could double check by trying the down printer's panel in the working one.

Sometimes the panel/cable can be an issue.

Good thing is you have a working printer that you can swap out parts to troubleshoot.

Mark
Logged
Mark Lindquist
z3200.com, MarkLindquistPhotography

plasakow

  • Newbie
  • *
  • Offline Offline
  • Posts: 14
Re: Z3200, known working PSU & formatter, printer doesn't boot.
« Reply #2 on: May 12, 2018, 08:28:09 PM »

Thanks.  Tried it.  Unfortunately, not the problem.
Logged

plasakow

  • Newbie
  • *
  • Offline Offline
  • Posts: 14
Re: Z3200, known working PSU & formatter, printer doesn't boot.
« Reply #3 on: May 13, 2018, 02:40:12 PM »

Update for future generations: it seems that, despite the obvious color-coding, I had swapped two connectors on the PSU board. 

Case embarrassingly closed.
Logged
Pages: [1]   Go Up