Pages: [1]   Go Down

Author Topic: Starting problem with Phaseone H20.  (Read 449 times)

Ganesh6667

  • Newbie
  • *
  • Offline Offline
  • Posts: 17
Starting problem with Phaseone H20.
« on: February 10, 2017, 12:26:59 PM »

Hi all,
With a lot of difficulty I somehow managed to enter the medium format through a used Phase One H20 V back on a Mamiya rb67 Pro S. The person who sold the DB back to me was of no help and with help from the forum at Lu-La, I managed to get an adapter to connect the DB to the Mamiya RB. Later got the cables and only recently got the whole act together. 
The following is the problem I am facing.
When I release the shutter, the output image is completely black (like unexposed). I tried with different settings but was of no help. I changed various lenses and with lot of variations of shutter and aperture,  somehow, on the wide 50mm C lens at T setting I got this image (87528)(87539) and I forgot to note down the settings, and even after numerous tires I could not repeat the process. However accidently while checking if the sync connection was all right, the flash tripped and Lo I had an image (87550).
I replicated the process and the image was on the screen.
It sound weird, but this is how it goes-
On the wide 50mm lens, the shutter is set to T and the desired aperture. The sync and the flash sync cables are connected. I release the shutter. The lens is on Mirror up. Next I release the mirror up with a cable release and disconnect the lens sync cable from the DB end and in one swift action reconnect the cable back to the DB and the flash fires immediately, the image appears on the laptop screen.
Without the above process the flash does not trip and I get the completely unexposed image or the other type of image.
I have tried to explain as best as I can.
HELP!!!
I need to know what needs to be done to get the back going, and me getting back to medium format photography.
Thanking you in advance. 
Best regards.
Ganesh.     
Logged
Pages: [1]   Go Up