Pages: [1] 2   Go Down

Author Topic: Viewing Linked Images  (Read 13187 times)

Peter McLennan

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1895
Viewing Linked Images
« on: May 27, 2006, 03:25:52 PM »

When I click on image thumbnails in posts, I get a new window that's full of ASCII, not the image.  Both IE and Firefox exhibit this new behaviour.   Embedded images (no thumbnail) load fine.

What's happening?  

Peter
Logged

Eric Myrvaagnes

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 10571
    • http://myrvaagnes.com
Viewing Linked Images
« Reply #1 on: May 27, 2006, 06:08:44 PM »

This has happened to me, too, for the past several days. My principal browser is Opera, which generally works fine. I got the same result with Firefox, but I was able to get an image on IE, which I am very reluctant to use, for many reasons.

I was wondering if the garbage was a side effect of a recent Microsoft upgrade. I am running XP professional with Service Pack 2 and all of the current security upgrades.

I also tried downloading the file from the link to open it locally, but that doesn't work either.

Anybody have any ideas?

Eric  
Logged
-Eric Myrvaagnes

http://myrvaagnes.com  Visit my photo website. New images each season. Also visit my new website: http://ericneedsakidney.org

Gary Brown

  • Full Member
  • ***
  • Offline Offline
  • Posts: 211
Viewing Linked Images
« Reply #2 on: May 27, 2006, 06:31:38 PM »

The server is sending a JPEG image but telling the browser that it's HTML, so it displays as garbage.

One way to view it is to right-click on it, "Save link as" (or the corresponding option depending on browser) and give it an appropriate name, like something.jpg, and then look at the resulting file on your disk.
Logged

Eric Myrvaagnes

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 10571
    • http://myrvaagnes.com
Viewing Linked Images
« Reply #3 on: May 27, 2006, 09:25:04 PM »

Quote
The server is sending a JPEG image but telling the browser that it's HTML, so it displays as garbage.

One way to view it is to right-click on it, "Save link as" (or the corresponding option depending on browser) and give it an appropriate name, like something.jpg, and then look at the resulting file on your disk.
[a href=\"index.php?act=findpost&pid=66745\"][{POST_SNAPBACK}][/a]
That works, but is very cumbersome.

Can somebody please fix the code (it looks like PHP code) so that "Click to enlarge" works the way it always used to?

Thanks for the work-around, Gary.

Eric
Logged
-Eric Myrvaagnes

http://myrvaagnes.com  Visit my photo website. New images each season. Also visit my new website: http://ericneedsakidney.org

michael

  • Administrator
  • Sr. Member
  • *****
  • Offline Offline
  • Posts: 5084
Viewing Linked Images
« Reply #4 on: May 27, 2006, 09:30:46 PM »

Looking into it.

Michael
Logged

Peter McLennan

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1895
Viewing Linked Images
« Reply #5 on: May 28, 2006, 12:55:55 AM »

Thank you!
Logged

Eric Myrvaagnes

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 10571
    • http://myrvaagnes.com
Viewing Linked Images
« Reply #6 on: May 28, 2006, 08:49:07 AM »

Quote
Thank you!
[a href=\"index.php?act=findpost&pid=66763\"][{POST_SNAPBACK}][/a]
Ditto.  
Logged
-Eric Myrvaagnes

http://myrvaagnes.com  Visit my photo website. New images each season. Also visit my new website: http://ericneedsakidney.org

David White

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 272
    • http://
Viewing Linked Images
« Reply #7 on: June 02, 2006, 11:13:11 PM »

Quote
When I click on image thumbnails in posts, I get a new window that's full of ASCII, not the image.  Both IE and Firefox exhibit this new behaviour.   Embedded images (no thumbnail) load fine.
[a href=\"index.php?act=findpost&pid=66738\"][{POST_SNAPBACK}][/a]

I'm still seeing it in Firefox.  IE works OK, but I try to avoid using it.  I just had it happen with the thumbnails in the post by gabrielmoss in the User Critiques forum.  Seems like it used to work OK.
Logged
David White

Eric Myrvaagnes

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 10571
    • http://myrvaagnes.com
Viewing Linked Images
« Reply #8 on: June 03, 2006, 02:54:51 PM »

Quote
I'm still seeing it in Firefox.  IE works OK, but I try to avoid using it.  I just had it happen with the thumbnails in the post by gabrielmoss in the User Critiques forum.  Seems like it used to work OK.
[a href=\"index.php?act=findpost&pid=67238\"][{POST_SNAPBACK}][/a]

Yes, it did used to work OK.

I use Opera (currently version 8.54), and I just went back to some earlier posts where I know I was able to "click to enlarge" successfully, and those no longer work. I get a new window with the code-garbage in Opera 8.54, in Firefox 1.07, and in Netscape 8.0.3.3. Curiously, when I try IE 6.0 (which I generally avoid whenever possible), the same thing works properly: A new window is opened with the enlarged image displayed. These are all on a PC; Macs may behave differently.

So something within the last two weeks seems to have broken something at the LL end. I do hope it gets repaired soon, because I definitely do not want to have to use IE for LL and Opera or Firefox for everything else.

Eric    
Logged
-Eric Myrvaagnes

http://myrvaagnes.com  Visit my photo website. New images each season. Also visit my new website: http://ericneedsakidney.org

Gary Brown

  • Full Member
  • ***
  • Offline Offline
  • Posts: 211
Viewing Linked Images
« Reply #9 on: June 03, 2006, 03:58:10 PM »

Quote
Curiously, when I try IE 6.0 (which I generally avoid whenever possible), the same thing works properly: A new window is opened with the enlarged image displayed.
[a href=\"index.php?act=findpost&pid=67288\"][{POST_SNAPBACK}][/a]

That's actually a bug in IE (although Microsoft considers it a feature). In general, IE ignores the Content-Type specified by the server, and instead looks at the data and tries to infer what it is, to decide how to process it. In cases like this, where the server is indicating the wrong type, IE will sometimes end up doing the "right" (from the end user's point of view) thing by doing the wrong thing.
Logged

jule

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 738
    • http://www.juliestephenson.net
Viewing Linked Images
« Reply #10 on: June 04, 2006, 12:23:22 AM »

I too am using Firefox, PC with Windows XP, and I just end up with ASCII gobleegook when I click on the thumbnail  to view images. I used to be able to view images perfectly well, until say...roughly a week or so ago. I would rather not to have to 'save link as' for each image. Any other options???

Julie

JRandallNichols

  • Jr. Member
  • **
  • Offline Offline
  • Posts: 72
Viewing Linked Images
« Reply #11 on: June 07, 2006, 02:01:21 PM »

As of June 7 the problem remains. at least for Firefox.
Logged
Randy

Eric Myrvaagnes

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 10571
    • http://myrvaagnes.com
Viewing Linked Images
« Reply #12 on: June 07, 2006, 09:45:27 PM »

Quote
As of June 7 the problem remains. at least for Firefox.
[a href=\"index.php?act=findpost&pid=67632\"][{POST_SNAPBACK}][/a]
And for Opera and Netscape.    

Eric
Logged
-Eric Myrvaagnes

http://myrvaagnes.com  Visit my photo website. New images each season. Also visit my new website: http://ericneedsakidney.org

michael

  • Administrator
  • Sr. Member
  • *****
  • Offline Offline
  • Posts: 5084
Viewing Linked Images
« Reply #13 on: June 07, 2006, 10:47:34 PM »

We're looking for the problem. No need for more "me too" messages.

Michael
Logged

mguertin

  • Guest
Viewing Linked Images
« Reply #14 on: June 07, 2006, 11:16:55 PM »

Quote
That works, but is very cumbersome.

Can somebody please fix the code (it looks like PHP code) so that "Click to enlarge" works the way it always used to?

Thanks for the work-around, Gary.

Eric
[a href=\"index.php?act=findpost&pid=66753\"][{POST_SNAPBACK}][/a]

I'm looking into this issue.  Unfortunately the click to enlarge seems to be something that Invision has removed from their code, not sure if it was due to security issues or not, but there were changes fairly recently within a security update.  

More info to follow as I track this one down.

Mark
Logged

mguertin

  • Guest
Viewing Linked Images
« Reply #15 on: June 08, 2006, 12:58:46 AM »

Testing attachments, please ignore the man behind the curtain
Logged

dlashier

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 518
    • http://www.lashier.com/
Viewing Linked Images
« Reply #16 on: June 08, 2006, 01:06:46 AM »

Quote
Testing attachments, please ignore the man behind the curtain
[{POST_SNAPBACK}][/a]

Still bad:
HTTP/1.1∑200∑OK(CR)(LF)
Date:∑Thu,∑08∑Jun∑2006∑05:04:36∑GMT(CR)(LF)
Server:∑Apache/1.3.36∑(Unix)∑mod_auth_passthrough/1.8∑mod_log_bytes/1.2∑mod_bwlimited/1.4∑PHP/4.4.2∑FrontPage/5.0.2.2635.SR1.2∑mod_ssl/2.8.27∑OpenSSL/0.9.7a(CR)(LF)
X-Powered-By:∑PHP/4.4.2(CR)(LF)
Connection:∑close(CR)(LF)
Transfer-Encoding:∑chunked(CR)(LF)
Content-Type:∑text/html(CR)(LF)
(CR)(LF)

If you don't know about it already, [a href=\"http://www.rexswain.com/httpview.html]Rexswain[/url] is a good tool to debug headers.

- DL
Logged

David White

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 272
    • http://
Viewing Linked Images
« Reply #17 on: June 08, 2006, 01:53:10 AM »

Amazing what you can find in the ASCII when you try to open thumbnails.  Found this in a posting when I tried to view the thumbnail.  I x'd out the user's name  to protect the guilty.    

application/vnd.adobe.photoshop  ¬©2005 xxxxxxxx   xxxxxxxx  Adobe Photoshop CS3 (10.0x20060119 [20060119.m.477 2006/01/19:02:00:00 cutoff; m branch]) Macintosh  2004-08-04T15:21:15-06:00  2006-03-08T10:12:35-07:00
Logged
David White

mguertin

  • Guest
Viewing Linked Images
« Reply #18 on: June 08, 2006, 01:59:59 AM »

Yep there are always large amounts of string data within most image formats.  In fact this holds true for more than just images, and has gotten a few people in trouble in the past.  For example, Word, by default, keeps an audit trail of all users that have edited the file (unless you find the specific setting to disable this in the file).  For OSX users the command line utility strings is very handy for this sort of stuff

Thanks for the tips on the headers, I generally use the built in stuff in Firefox for this.  Not sure why we are getting the wrong mime type set (yet), but working on it and have a trouble ticket opened for this one.

More info as I get it, stay tuned everyone and thanks.

Mark
Logged

jani

  • Sr. Member
  • ****
  • Offline Offline
  • Posts: 1620
    • ōyet
Viewing Linked Images
« Reply #19 on: June 18, 2006, 08:41:14 PM »

Quote
Thanks for the tips on the headers, I generally use the built in stuff in Firefox for this.  Not sure why we are getting the wrong mime type set (yet), but working on it and have a trouble ticket opened for this one.
Alhough I'm a bit too tired to say with certainty whether the following is relevant when PHP can set its own HTTP headers, consider the following anyway, but don't chase the geese for too long.

One typical reason is that the hosting provider sets a new configuration option in Apache, or that there is one set in .htaccess.  It is also possible that the Apache configuration has been changed to disallow PHP/CGI/whatever from overriding content type etc.

You might want to check if someone removed the option of overriding FileInfo (http://httpd.apache.org/docs/1.3/mod/core.html#allowoverride).
Logged
Jan
Pages: [1] 2   Go Up